[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: all-wcprops out of date problem

From: Qiao Lian (Ch'iao Lien) <lianqiao_at_gmail.com>
Date: 2007-03-21 04:35:23 CET

Hey guys, I solved the problem. the SVN can not be configured in root
directory. Max answers in this post:
http://svn.haxx.se/users/archive-2004-09/0210.shtml

On 3/20/07, Qiao Lian (Ch'iao Lien) <lianqiao@gmail.com> wrote:
> hi:
> I have used subversion for some years, but recently run into this
> buggy problem:
> after submit a new commit for file, the version number in all-wcprops
> doesn't update (inc by one). The consequence is that following commit
> will report out of date error.
>
> For example, I have a file called testbot.py, its version is 64. like this:
> ===========================.svn/entries=========================
> ...
> testbot.py
> file
> 64
>
>
>
>
> 2007-03-20T12:27:56.000000Z
> eae69389250ed742e32c15d90b96e5f9
> 2007-03-20T05:03:18.227598Z
> 64
> lianqiao
> ...
> ===========================.svn/entries=========================
> ===========================.svn/all-wcprops=====================
> ...
> testbot.py
> K 25
> svn:wc:ra_dav:version-url
> V 29
> /!svn/ver/64/build/testbot.py
> END
> ...
> ===========================.svn/all-wcprops=====================
>
> After I changed and commited, its version should updated to version
> 65. like this:
> ===========================.svn/entries=========================
> ...
> testbot.py
> file
>
>
>
>
> 2007-03-20T12:29:58.000000Z
> af5574155fe1e45325a88d3ed21c26c6
> 2007-03-20T10:47:31.704660Z
> 65
> lianqiao
> ...
> ===========================.svn/entries=========================
> ===========================.svn/all-wcprops=====================
> ...
> testbot.py
> K 25
> svn:wc:ra_dav:version-url
> V 29
> /!svn/ver/65/build/testbot.py
> END
> ...
> ===========================.svn/all-wcprops=====================
>
> however I found that the all-wcprops is unchanged. the line
> /!svn/ver/65/build/testbot.py is still /!svn/ver/64/build/testbot.py
>
> If I choose update to version 64 and then update back to version 65,
> the all-wcprops can changes to ver 65. I am wondering is this a bug?
>
> I have already used the latest version of tortoiseSVN, and I also meet
> this problem on command line svn util ver: svn, version 1.4.2
> (r22196). So I am wondering this is server configuration problem.
>
> Can anybody help me? (I can setup a account for troubleshooting).
>
> Many thanks
>
> Qiao
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Wed Mar 21 04:35:59 2007

This is an archived mail posted to the Subversion Users mailing list.