[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: SVN client on RedHat 7.2

From: Ryan Schmidt <subversion-2007a_at_ryandesign.com>
Date: 2007-03-08 07:14:43 CET

On Mar 7, 2007, at 16:33, Thomas Despoix wrote:

>> Subversion does not require Apache 2. Subversion can use Apache 2,
>> and if you want to serve a repository over the http or https
>> protocols, you will need Apache 2. But if you just want to access
>> other repositories, you don't need Apache 2.
>>
>> To access http repositories, you need neon. To access https
>> repositories, you need neon compiled with openssl support.
>>
>> Subversion always needs apr and apr-util.
>
> Thanks for your information. Yet, even if I'm not fully familiar
> with installing packages and dependency rules, I'm probably missing
> something but when i do something like :
>
> > rpm -ivh subversion-tools-1.3.2-1.rh7x.i386.rpm
>
> Here is rpm's answer :
>
> error: failed dependencies:
> apache-libapr >= 2.0.48-0.1 is needed by subversion-1.3.2-1
> neon >= 0.24.7 is needed by subversion-1.3.2-1
> python2 is needed by subversion-1.3.2-1
> libapr-0.so.0 is needed by subversion-1.3.2-1
> libaprutil-0.so.0 is needed by subversion-1.3.2-1
> libcrypto.so.2 is needed by subversion-1.3.2-1
> libneon.so.24 is needed by subversion-1.3.2-1
> libssl.so.2 is needed by subversion-1.3.2-1
>
> Doesn't that mean I somehow need some Apache librapr up to a 2.0.x
> version for instance?
>
> When I try to install neon, I get :
> zlib >= 1.1.4 is needed by neon-0.24.7-1
> libcrypto.so.2 is needed by neon-0.24.7-1
> libssl.so.2 is needed by neon-0.24.7-1
>
> Finally, where do I find libapr and libapr util, as well
> libcrypto and libssl ?
>
> It sounds like I have many package to install or upgrade. Is that
> correct, or am I totally missing something ?

I don't use Red Hat or RPMs so all I can tell you is what Subversion
requires on its own; how your RPMs are configured I have no idea.

Subversion requires apr and aprutil. These are provided by the Apache
Software Foundation (but are unrelated to the Apache web server
project). apr and aprutil are available from http://apr.apache.org/

There is no "apr 2.0." There is apr 0.9 and 1.2. apr 0.9 comes with
the apache web server 2.0, and apr 1.2 comes with the apache web
server 2.2. If you want to serve your repositories using the apache
web server, you will need to match up the version of apr between the
apache web server and subversion. (If you want to serve with apache
2.0.x, you need to build subversion with apr 0.9; if you want to
serve with apache 2.2.x, you need to build subversion with apr 1.2.)
If you do not want to serve your repository with the apache web
server, then it does not really matter which version of apr you build
it with, except that newer versions are of course better in general.

Subversion needs neon to connect to http-based repositories. If you
want to access http repositories, get neon, from http://
www.webdav.org/neon/.

If you want to connect to https-based repositories, you need to build
neon with openssl support. libssl and libcrypto are provided by
openssl. http://www.openssl.org/

Since neon seems to need zlib, get the latest version of that from
http://www.zlib.net/

Subversion does not need python, but can optionally create language
bindings for it.

If you cannot replace this with a more modern OS that already has up-
to-date libraries, I imagine it would be easiest for you to build
subversion and all its dependencies from source into a unique
directory just for this purpose (/usr/local/subversion for example).

-- 
To reply to the mailing list, please use your mailer's Reply To All  
function
---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Thu Mar 8 07:15:22 2007

This is an archived mail posted to the Subversion Users mailing list.