[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

swig-pl build problem

From: Mark Lundquist <mlundquist2_at_comcast.net>
Date: 2007-01-18 09:23:07 CET

Hi,

I've been trying to build the SWIG Perl binding in Subversion 1.4.2 on
OS X. I'm using Perl 5.8.6 recently installed via Fink. I'm doing this
as part of an effort to install svk, and I actually installed swig-pl
successfully before this, but I was getting errors in svk that looked to
me like I needed a newer version of Perl than the one (5.8.1) from the
Panther distribution, so I installed the latest Perl I can get using
Fink, re-ran configure with PERL=/sw/bin/perl, did "make clean-swig-pl",
then "make swig-pl check-swig-pl", and here is what I get:

---------------------------------------
/sw/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib',
'blib/arch')"
../../../../../subversion/bindings/swig/perl/native/t/*.t../../../../../subversion/bindings/swig/perl/native/t/0use.............#
     Failed test
(../../../../../subversion/bindings/swig/perl/native/t/0use.t at line 6)
# Tried to use 'SVN::Repos'.
# Error: Can't locate loadable object for module SVN::_Repos in
@INC (@INC contains:
/Volumes/codeshack-data1/ml/software/Subversion/subversion-1.4.2/subversion/bindings/swig/perl/native/blib/lib
/Volumes/codeshack-data1/ml/software/Subversion/subversion-1.4.2/subversion/bindings/swig/perl/native/blib/arch
/sw/lib/perl5 /sw/lib/perl5/darwin
/sw/lib/perl5-core/5.8.6/darwin-thread-multi-2level
/sw/lib/perl5-core/5.8.6/darwin-thread-multi-2level
/sw/lib/perl5-core/5.8.6
/sw/lib/perl5/site_perl/5.8.6/darwin-thread-multi-2level
/sw/lib/perl5/site_perl/5.8.6/darwin-thread-multi-2level
/sw/lib/perl5/site_perl/5.8.6
/sw/lib/perl5/site_perl/5.8.6/darwin-thread-multi-2level
/sw/lib/perl5/site_perl/5.8.6
/sw/lib/perl5/site_perl/5.8.6/darwin-thread-multi-2level
/sw/lib/perl5/site_perl .
/sw/lib/perl5-core/5.8.6/darwin-thread-multi-2level
/sw/lib/perl5-core/5.8.6
/sw/lib/perl5/site_perl/5.8.6/darwin-thread-multi-2level
/sw/lib/perl5/site_perl/5.8.6
/sw/lib/perl5/site_perl/5.8.6/darwin-thread-multi-2level
/sw/lib/perl5/site_perl .) at
/Volumes/codeshack-data1/ml/software/Subversion/subversion-1.4.2/subversion/bindings/swig/perl/native/blib/lib/SVN/Base.pm
line 59
# BEGIN failed--compilation aborted at
/Volumes/codeshack-data1/ml/software/Subversion/subversion-1.4.2/subversion/bindings/swig/perl/native/blib/lib/SVN/Repos.pm
line 5.
# Compilation failed in require at (eval 4) line 2.
----------------------------------------

Note, my subversion/bindings/perl/native/blib/lib contains Base.pm,
Repos.pm, Ra.pm, etc...

I must've botched something, any idea what?

Thx-a-lot,
—ml—

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Thu Jan 18 09:36:34 2007

This is an archived mail posted to the Subversion Users mailing list.