[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Help upgrading from SVN 1.2 to 1.4 on Debian

From: Ron Kim <ron_at_e-learnings.co.nz>
Date: 2006-09-28 07:20:24 CEST

Hi,
 
I'm in the process of upgrading Subversion 1.2 to 1.4 on Debian.
I am quite unexperienced with Linux so please bear with me!
 
According to an internal documentation, version 1.2 had been installed
by
running 'apt-get install -t unstable subversion subversion-tools'.
So I ran 'apt-get -t unstable install subversion subversion-tools' and
the following is the result.
 
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
  kernel-image-2.6.8-2-386: Depends: initrd-tools (>= 0.1.63) but it is
not going to be installed
  subversion: Depends: libsvn0 (= 1.4.0-2) but 1.2.0-1 is to be
installed
              Depends: libapr0 (>= 2.0.55) but 2.0.54-5 is to be
installed
              Depends: libc6 (>= 2.3.6-6) but 2.3.2.ds1-22 is to be
installed
              Depends: libsvn0 (>= 1.4.0) but 1.2.0-1 is to be installed
  subversion-tools: Depends: python-subversion (>= 1.4) but it is not
going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or
specify a solution).
 

What is meant by the above message and what actions need to be taken?
 
I've tried running apt-get update. It looks like sources.list is not
that extensive too.
My guess is I need to add some source that has the installation files to
the list.
Am I close at all?
 
Thanks in advance. Any input would be much appreciated!
 

Yours sincerely,

Ron Kim

Developer, e-learnings Asia Pacific Limited
http://www.e-learnings.co.nz
<blocked::blocked::http://www.e-learnings.co.nz>
a subsidiary of Auckland UniServices Limited
Level 10, UniServices House
70 Symonds Street, Auckland
http://www.uniservices.co.nz <blocked::http://www.uniservices.co.nz/>
Office: (+64-9) 373-7522 ext. 86606
Mobile: 021 33 7878

 

--------------------------------------------------------------------------------
CAUTION: This email message and accompanying data may contain information that
is confidential and subject to legal privilege. If you are not the intended
recipient, you are notified that any use, dissemination, or copying of any part
of this message and accompanying data, is prohibited. If you have received
this message in error, please notify me immediately and delete this email
message from your computer. Thank you. Please also note that this message may
have been intercepted and modified by unknown third parties prior to its
receipt by you.
--------------------------------------------------------------------------------
Received on Thu Sep 28 07:21:01 2006

This is an archived mail posted to the Subversion Users mailing list.