[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: !svn/vcc/default on WinXP

From: Frank Segust <franksegust_at_hotmail.com>
Date: 2005-02-25 10:56:46 CET

Hi Ben,

I have fixed the problem. It was, as you said, nothing to do with
Subversion, but was a bug in Windows XP TCP/IP handling.

To fix it I:

1. Upgraded to XP Service Pack 2
2. Disabled XP firewall - have one on my modem/router
3. Disabled the Automatic Update feature (this uses port 443)

All works fine now.

Thanks for your time,

--Frank

>From: Ben Collins-Sussman <sussman@collab.net>
>To: "Frank Segust" <franksegust@hotmail.com>
>CC: users@subversion.tigris.org
>Subject: Re: !svn/vcc/default on WinXP
>Date: Fri, 18 Feb 2005 07:55:54 -0600
>
>
>On Feb 18, 2005, at 3:35 AM, Frank Segust wrote:
>
>>Hi Ben,
>>
>>Thanks for your reply.
>>
>>Below is a transcript of the error. I get exactly the same problem using
>>either command line 'svn' or using Tortoise. One thing I have noticed is
>>that by attempting repeated 'svn update' commands I can get a variety of
>>errors. They are listed below.
>>
>>
>>Error 1
>>---------
>>
>>svn: REPORT request failed on '/svn/bruinknits/!svn/vcc/default'
>>svn: REPORT of '/svn/bruinknits/!svn/vcc/default': Could not read response
>>body:
>>SSL error: wrong version number (https://benwimpory.myip.org)
>>
>>
>>Error 2
>>---------
>>
>>svn: REPORT request failed on '/svn/myproject/!svn/vcc/default'
>>svn: REPORT of '/svn/myproject/!svn/vcc/default': Could not read chunk
>>delimite
>>r: SSL error: wrong version number (https://my.domain.com)
>>
>>Error 3
>>---------
>>
>>svn: REPORT request failed on '/svn/bruinknits/!svn/vcc/default'
>>svn: REPORT of '/svn/bruinknits/!svn/vcc/default': Could not read chunk
>>delimite
>>r: SSL error: decryption failed or bad record mac
>>(https://benwimpory.myip.org)
>>
>
>None of these errors have anything to do with Subversion -- they look like
>low-level SSL errors. So there's something wrong with the network layer.
>Somehow apache's mod_ssl and the client library (neon, using openssl
>libraries) aren't able to communicate. Incompatible SSL versions? Dunno.
>
>Try doing stuff without SSL as a workaround... or find an SSL expert. This
>is beyond me.
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
>For additional commands, e-mail: users-help@subversion.tigris.org
>

_________________________________________________________________
Surf the net and talk on the phone with Xtra JetStream @
http://xtra.co.nz/jetstream

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Fri Feb 25 10:59:14 2005

This is an archived mail posted to the Subversion Users mailing list.