[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Solaris report: Subversion-1.0.0

From: Stefan Urbat <stefan.urbat_at_apastron.lb.shuttle.de>
Date: 2004-02-24 19:47:22 CET

On Tue, 24 Feb 2004, Sander Striker wrote:

> On Tue, 2004-02-24 at 15:15, Philip Martin wrote:
> > Sander Striker <striker@apache.org> writes:
> >
> > >> Do you know where '-lpthread' is missing? Can you submit a patch? :-)
> > >
> > > IIRC, this is due to the fact that your OS isn't up to the latest patch
> > > level. I've seen this before, but didn't need to change the source,
> > > only external conditions.
> >
> > The missing -lpthread in link commands is a symptom of the use of
> > Debian's libtool-1.4.3 in the tarball. I don't think it's a problem
> > with the OS being out of date, and there is not really anything to
> > patch.
>
> I encountered it when building from the repository on Solaris,
> with the libtool installed on that machine. The problems
> went away after updating. But hey, disregard that weird datapoint ;).
>
Okay, things seem to have cleared up now --- I will try to replace
libtool, which seems to be the culprit, possibly also on HP-UX 11 and AIX
4.3.3 (on HP-UX I omitted -lz and lost the zlib compression that way, on
AIX 4.3.3 I encountered a strange error absent on AIX 5.2L, will report
later on for those platforms too; we develop on a multitude on platforms,
and only GNU/Linux is easy living thanks to the Debian binary
packages... and hopefully Mž Windows will turn out easy too with EXEs
for installation; a colleague compiled it already on Mac OS X
successfully).

--
Registered Linux-User #169380 on http://counter.li.org/
---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Tue Feb 24 19:47:04 2004

This is an archived mail posted to the Subversion Users mailing list.