[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Can't connect to subversion server

From: Francois Beausoleil <fbos_at_users.sourceforge.net>
Date: 2004-01-22 00:17:42 CET

Here is a part of my httpd.conf file:

### Subversion Configuration
LoadModule dav_svn_module G:/Subversion/httpd/mod_dav_svn.so
LoadModule authz_svn_module G:/Subversion/httpd/mod_authz_svn.so

As you can see, I put in the paths to the installed libraries. This way,
I do not have to remember to upgrade my server's SOs whenever I upgrade
Subversion. It works much better this way, believe me :)

Hope that helps !
François

On Wed, 21 Jan 2004 17:47:52 -0500, "Jack Ivey" <ivey@altair.com> said:
> Hi all,
> I had the same problem as Natalya (complaints about format 3 vs 2). I
> installed the Win32 packaged install today (svn-0.36.0-setup.exe) and had
> never installed an earlier version.
>
> It appears that when you install the package with debug symbols (the
> default?),
> the command-line executables and Apache plugins that are loaded have been
> built
> with different versions of db4. I know this because the command line
> utilities required libdb40.dll and the Apache plugins required
> libdb42.dll
> to be present in order to work at all. If you uninstall Subversion,
> deleting
> all the remaining debris in Program Files and then reinstall without the
> debug
> symbols it works much better.
>
> You still have to copy libdb42.dll, libeay32.dll, ssleay32.dll,
> mod_dav_svn.so and mod_authz_svn.so into the Apache modules directory.
>
> Thanks,
> Jack
>
>
>
> > -----Original Message-----
> > From: Natalya Pyalling [mailto:npyalling@valuecommerce.ne.jp]
> > Sent: 21 January 2004 05:27 PM
> > To: users@subversion.tigris.org
> > Subject: Can't connect to subversion server
> >
> > Hi all,
> >
> > I am newbie in Subversion. I installed it with Apache 2. I added some
> lines
> > to Apache config
> >
> > <Location /svn/repos>
> > DAV svn
> > SVNPath /home/svnroot
> >
> > # Limit write permission to list of valid users.
> > <LimitExcept GET PROPFIND OPTIONS REPORT>
> > # Require SSL connection for password protection.
> > # SSLRequireSSL
> >
> > # AuthType Basic
> > # AuthName "Authorization Realm"
> > # AuthUserFile /absolute/path/to/passwdfile
> > # Require valid-user
> > </LimitExcept>
> > </Location>
> >
> > I created a repository
> >
> > svnadmin create /home/svnroot
> >
> > But when I tried to connect server, I got a couple of lines in
> ssl_error_log
> >
> > [Wed Jan 21 23:10:21 2004] [error] [client 10.1.2.110] (20014)Error string
> > not specified yet: Expected version '3' of repository; found version '2'
> > [Wed Jan 21 23:10:21 2004] [error] [client 10.1.2.110] Could not fetch
> > resource information. [500, #0]
> > [Wed Jan 21 23:10:21 2004] [error] [client 10.1.2.110] Could not open the
> > requested SVN filesystem [500, #165005]
> > [Wed Jan 21 23:10:21 2004] [error] [client 10.1.2.110] (84)Invalid or
> > incomplete multibyte or wide character: Could not open the requested SVN
> > filesystem [500, #165005]
> >
> > Would you like point me to error? What can I do wrong?
> >
> > Any help would be appreciated.
> >
> > Thank you very much for your time.
> >
> > Sincerely yours,
> > Natalya Pyalling.
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
> For additional commands, e-mail: users-help@subversion.tigris.org
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Thu Jan 22 00:18:41 2004

This is an archived mail posted to the Subversion Users mailing list.