[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Subversion 0.30.0 stability problems : not able to check in bigger pieces

From: Brian Mathis <bmathis_at_directedge.com>
Date: 2003-10-07 18:59:06 CEST

This sounds to me very much to be a memory problem. You are probably
running out of it. How large is the data you are checking in?

The fact that things are slowing down sounds like it is probably using
the pagefile.

My suggestion is to open 2 windows to the server, run 'top' in 1 and run
the checkout in the other. Watch the memory usage and see what happens.
  When you start top, press capital 'M' to sort by memory usage.

Roland Schwingel wrote:
> Hi....
>
> As you might know I got problems with subversion concerning speed and
> stability... I found something new (and unfortunately bad)... At least for
> me...
>
> I am running Suse Linux 8.0 on a Dual AMD 1600MP machine with 512MB Ram.
> Kernel 2.4.20.
> apache2 2.0.47
> berkeley db 4.1.25
> subversion 0.30.0
>
> I tried the following (checkin apache 2.0.47 source) to test stability
> about 10 times and it never finished....
>
> rm -rf /path/to/test_repos
> svnadmin create /path/to/test_repos
> # recover ist just to be sure due to my recent problems, but it doesn't
> matter if I use it here or not
> svnadmin recover /path/to/test_repos
> svn co http://svnserver/svn/test_repos svn_test
> cd svn_test
> tar xvfz /path/to/httpd-2.0.47.tar.gz
> svn add *
> svn ci -m test
>
> It starts to check in first very fast, later it gets slower and slower and
> finally gets stuck...
> ...
> Adding httpd-2.0.47/test/test_parser.c
> Adding httpd-2.0.47/test/test_select.c
> Adding httpd-2.0.47/test/time-sem.c
> Adding httpd-2.0.47/test/zb.c
> Transmitting file data
> .......................................................................................................................................................................................................................................................................................................................................................................................................................................................................svn:
> RA layer request failed
> svn: Commit failed (details follow):
> svn: PUT of
> /svn/test_repos/!svn/wrk/e19f3a86-13c9-0310-a9ec-de66ee5e4426/httpd-2.0.47
> /docs/manual/ssl/ssl_compat.xml.meta: timed out waiting for server
> (http://svnserver)
>
> The number of dots it paints varies, sometimes more sometimes less (and
> therefore never fails at the same file to checkin). I am the only one who
> uses svn here so there is no concurrency.
>
> And sometimes something also appears to segfault...
> from apache's error_log:
> [Tue Oct 07 09:11:18 2003] [notice] child pid 23267 exit signal
> Segmentation fault (11)
> It appears soon before "svn: RA layer request failed" Not always but about
> 20% of my tests....
>
> Yet it appears to me that 0.30.0 is not really useable...
> Is someone else also having these problems?
>
> Roland
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
> For additional commands, e-mail: users-help@subversion.tigris.org

-- 
Brian Mathis
http://www.directedge.com/b/
---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Tue Oct 7 19:00:19 2003

This is an archived mail posted to the Subversion Users mailing list.