[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Missing Error Messages

From: Arthur Schwarz <aschwarz1309_at_att.net>
Date: Wed, 1 Dec 2010 11:04:46 -0800 (PST)

Thanks Stefan;

The message is:

"To better debug SSH connection problems, remove the -q option from 'ssh' in the
[tunnels] section of your Subversion configuration file.
Network connection closed unexpectedly"

The error was that the password was incorrect in the
TSVN->Settings->Network->SSH entry. When the password was changed to the correct
value, everything worked fine.

The requirement on [tunnels] ssh options that TortoisePlink must be substituted
with another 'ssh' client is not in the comments. Is there any way that the next
release of TSVN can put in conditions-of-use for using ssh in [tunnels] and the
diagnostic comment above be changed? And, is there any way to remove the
requirement that TortoisePlink be removed and another SSH be used or can an
option be provided to TortoisePlink to remove '-q' and/or to provide other
options.

Thanks. You have really been a help.
art

________________________________
From: Stefan Küng <tortoisesvn_at_gmail.com>
To: users_at_tortoisesvn.tigris.org
Sent: Wed, December 1, 2010 10:05:25 AM
Subject: Re: Missing Error Messages

On 01.12.2010 18:55, Arthur Schwarz wrote:
> Thanks Dale;
>
> I'm included part of the Settings file with my changes inserted. My
> assumption is that 'ssh=ssh' informs TSVN to substitute 'ssh' in
> 'svn+ssh://' during URL / command execution. I would like to get more
> diagnostic information. The output message indicated that a change had
> to be made in [tunnels] section of the Settings file. Is this the
> correct change?
>
> I really don't understand what's going on. The comments indicate that
> 'only the ssh' command is defined, but the original ssh command (# ssh =
> $SVN_SSH ssh -q) is commented out.
>
> The URL popup is (TSVN -> repo-browser):
>
> svn+ssh://schwarar@hbchwr98s007p1.ds.boeing.com/svn_repos/fse/MSO/
> | | |
> | | o hostname
> | o username
> o command
>
> Any help in understanding enough so I can solve problems on my own would
> be appreciated.

first: do you have an 'ssh' command on your machine?
second: TSVN first uses the command you entered in the settings dialog,
network page, bottom "ssh client". Only if that box is empty the ssh
setting from the config file is used.

  This requirement is not in the [tunnels] comments. Is there any way that
  this condition can be put there for the next release of TSVN?

Usually TortoisePlink is specified on that line.

And you mention an error message, but you fail to actually tell us the
exact error message you get.

Stefan

-- 
        ___
   oo  // \\      "De Chelonian Mobile"
  (_,\/ \_/ \     TortoiseSVN
    \ \_/_\_/>    The coolest Interface to (Sub)Version Control
    /_/   \_\    http://tortoisesvn.net
------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=2687058
To unsubscribe from this discussion, e-mail: 
[users-unsubscribe_at_tortoisesvn.tigris.org].
------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=2687071
To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2010-12-01 20:04:56 CET

This is an archived mail posted to the TortoiseSVN Users mailing list.