[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Bugtraq inconsistency with Subclipse

From: <Mark-Alan.West_at_telenor.com>
Date: Fri, 20 Aug 2010 13:59:36 +0200

Hello!

I am using TortoiseSVN 1.6.10.19898, running on Windows XP.

At the trunk of my source repo I have implemented the buqtraq SVN properties. My understanding is that all check-ins under the trunk will use these properties, even though the "Apply property recursively" checkbox is not checked. This understanding has been confirmed by testing.

The problem occurs when I add new directories under the trunk directory. The bugtraq SVN properties from trunk are explicitly added to the new directories when they are added to the SVN repo.

Not all the buqtraq properties are added - only the "label", "message", "url" & "warnifnoissue" seem to be copied.

I haven't been able to reproduce this behaviour with Subclipse, and am unsure of whether or not this is expected behaviour. In this case I feel that Subclipse is providing the expected behavour.

This can be a problem, especially if the bugtrap properties need to be updated. Should I raise this as an issue?

Regards
Mark Alan West

------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=2649210

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2010-08-20 14:24:05 CEST

This is an archived mail posted to the TortoiseSVN Users mailing list.