[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

RE: Re: Problem with keywords substitution

From: Mats Broberg <mabr_at_flir.se>
Date: Fri, 19 Mar 2010 02:21:21 -0700 (PDT)

> On Tue, Jan 19, 2010 at 07:03, Broberg, Mats <mabr_at_flir.se> wrote:
> > Hello,
> >
> > First poster, so pls be gentle if this is not the proper way to report
> > (what I think is) a bug.
> >
> > Since upgrading to version 1.6.6, I have had trouble making keyword
> > substitution work properly. It seems to work fine the first time in my
> > (XML) files, i.e., $Rev$, $Id$ etc. are correctly populated when
> > checking in the files.
> >
> > However, once the keywords are populated, substitution does not seem to
> > work for subsequent versions. The only way I can get those to work is to
> > strip the content to $Rev$, $Id$ etc. again.
>
> The keywords are only updated when the file has been changed. Keywords
> are not stored "populated" in the repository; they are expanded by the
> client when checking out or updating.

Andy,

Yes, I am aware of that.

However, all svn keyword substitutions except Date work as they should. Date does not work properly in 1.6.7.18415. The date is not updated when checking in, despite e.g. URL or Rev are updated correctly.

Best regards,
Mats Broberg

------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=2462059

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2010-03-19 10:21:28 CET

This is an archived mail posted to the TortoiseSVN Users mailing list.