[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Test merge fails, actual merge succeeds

From: Stefan Küng <tortoisesvn_at_gmail.com>
Date: Mon, 13 Jul 2009 20:16:11 +0200

Andrea wrote:
> Hi,
>
> I've had this situation (tortoise 1.6.3), connected to a server 1.5.X.
>
> I merge from branch 1 to branch 2 and I select rev 71 and from 87 to 89
> in the gui.
>
> Then I test the merge and some files in 87,88,89 fail to be merged.
> If I then run the actual merge everything works fine.
>
> Is it because changes 87-89 need 71 to apply properly? And Tortoise's
> Test Merge always tries to merge on the working copy.
> And then, when I do the actual merge 87 is applied on top of 71?

The test merge is just that: a test. It doesn't run the whole merge, so
the output is only guessed, not actually done. So while that guessing is
really good, it can't be 100% accurate since that can only be done by
actually executing the merge.

Stefan

-- 
        ___
   oo  // \\      "De Chelonian Mobile"
  (_,\/ \_/ \     TortoiseSVN
    \ \_/_\_/>    The coolest Interface to (Sub)Version Control
    /_/   \_\     http://tortoisesvn.net
------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=2371053
To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2009-07-13 20:16:23 CEST

This is an archived mail posted to the TortoiseSVN Users mailing list.