[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: error stealing lock in TSVN 1.5.8

From: Stefan Küng <tortoisesvn_at_gmail.com>
Date: Thu, 05 Mar 2009 09:19:08 +0100

Todd C. Gleason wrote:
> While running a test, I tried stealing a lock using TortoiseSVN 1.5.8
> and I got an error that the file was locked. It was the same error I
> get if I don’t check “steal the locks”:
>
>
>
> Command: Lock
>
> Error: Path '[path]' is already locked by user '[user]'
>
> Error: in filesystem '[svn internal path]'
>
> Finished!:
>
>
>
> I’m pretty sure this worked back in TortoiseSVN 1.5.3. The server is 1.5.2.
>
>
>
> Also, the Subversion 1.5.5 client, with option “—force”, seems to handle
> this fine and steals the lock as requested. Another workaround is to
> use the repo-browser to break the lock first.
>
>
>
> Is it possible that the “steal the locks” checkbox is being ignored?

I've tried this with the latest nightly build, and it works as expected.
And I don't see anything in my 1.5.x files that would suggest that the
checkbox is ignored.

Could you maybe try a nightly build?

Stefan

-- 
       ___
  oo  // \\      "De Chelonian Mobile"
 (_,\/ \_/ \     TortoiseSVN
   \ \_/_\_/>    The coolest Interface to (Sub)Version Control
   /_/   \_\     http://tortoisesvn.net
------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=1271149
To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].

Received on 2009-03-05 09:19:36 CET

This is an archived mail posted to the TortoiseSVN Users mailing list.