[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Bug Report: 'Unversioned files mark parent folder as modified' feature does not work for unversioned folders

From: Stefan Kueng <tortoisesvn_at_gmail.com>
Date: Mon, 22 Dec 2008 12:02:11 +0100

aolszowka wrote:
> **Note this bug was reported by Abram Pousada on Apr 8 2008, this
> report serves to add additional information**
>
> {{Summary}}
> TortoiseSVN's 'Unversioned files mark parent folder as modified'
> feature does not appear to behave as expected.
>
> {{Reproducible?}}
> Yes
>
> {{Steps To Reproduce}}
> Have a folder structure similar to the one listed below
>
> Example
> |-->Example1
> | |-->SomeUnversionedFolder
> |
> |-->Example2
> | |-->SomeUnversioned.File
> |
> |-->Example3
> | |-->SomeOtherUnversionedFolder
> | |--> SomeOtherUnversioned.File
>
>
> The expected result is that Example1,Example2, and Example3 folders
> should be marked as 'modified', however only Example2 is marked as
> 'modified'. I am not sure if this is the intended result as the
> description 'Unversioned files' seems to convey the idea of only
> looking at files, however I recall that earlier versions of
> TortoiseSVN behaved the same as the expected result (where folders
> were treated as 'files').
>
> {{Work Around}}
> The files and folders are still caught as unversioned when performing
> other tasks such as 'Delete unversioned items...' and 'Check for
> modifications' as well as 'SVN Commit', therefore this is not
> considered a serious issue unversioned folders and nested unversioned
> items can be identified using these functions. However you will not
> get a visual notification.
>
> {{Bug Previously Reported?}}
> Yes, it appears to have been reported by Abram Pousada on Apr 8 2008
> with the title 'Unversioned directories and modified icon overlay'.
> However there doesn't appear to have been any response (or it was sent
> to his personal email address). Also he was reporting this error in
> TortoiseSVN 1.4.8 Build 12137 (32 bit) under Windows XP Professional,
> the issue appears to be in the most current stable build as noted
> below.
>
> {{Version(s)}}
> Issue appears to be present in the latest stable build of TortoiseSVN
> 1.5.5, Build 14361 - 64bit downloaded from the official TortoiseSVN
> site. This was running on Windows Server 2008 x64 with the latest
> updates applied.
>
> The issue also appears to be present in the latest stable build of the
> 32bit version of Tortoise, this was tested on Windows XP SP3 x32 with
> the latest updates.

Thanks for the very detailed report!

Should be fixed in r14930 and will be available in the next (1.6) release.

Stefan

-- 
       ___
  oo  // \\      "De Chelonian Mobile"
 (_,\/ \_/ \     TortoiseSVN
   \ \_/_\_/>    The coolest Interface to (Sub)Version Control
   /_/   \_\     http://tortoisesvn.net
------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=989659
To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].

Received on 2008-12-22 12:02:39 CET

This is an archived mail posted to the TortoiseSVN Users mailing list.