[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Tortoise SVN : Repo browsing slowness on first view.

From: <kristiaand_at_googlemail.com>
Date: Tue, 29 Jul 2008 07:24:02 -0700 (PDT)

Hi Stefan,
thanks for the reply regarding this, the browser we are getting
problems with is the one from the right click menu in windows, the
menu wordings are as follow.

TortoiseSVN > Repo-Browser

most of the slowness is normally from the first attempt to view the
repository through this window, after this initial slow loading things
tend to speed up and work as normal.

my appologies if you get this message twice but google seemed to fail
to post it in the first attempt so i have rewritten it.

thanks
Kris Davies

On Jul 29, 10:31†am, Stefan KŁng <tortoise..._at_gmail.com> wrote:
> kristia..._at_googlemail.com wrote:
> > Hi Everyone,
> > wondering if someone can help me out abit.
>
> > firstly i have to say i am really, really new to using SVN and
> > tortoise so please be patient and clear with any replys as i am still
> > getting my head around all the little features and settings.
>
> > anyway onto my question / problem, our company is using SVN as a
> > repository for all its code etc, we are using a mixture of SVN clients
> > but the main one preferred by our developers is tortoise. in total we
> > have 5 developers that access the repo on a daily basis and over the
> > last month or so have been complaining more and more about a gradual
> > slowdown in using the repo browser in tortoise.
>
> > we are all †using the latest version of tortoise (1.5.1) which was
> > downloaded from the site about a week ago. when using the repo browser
> > for the first time in the morning everyone notices a delay in loading
> > the folders of around 4 - 5 minutes, we have tried just one person
> > incase all 5 were having a combined slowdown, and nothing seems to
> > improve it.
>
> > I have done some googling and followed the information provided here
> > (http://tortoisesvn.net/node/14) but that has made no difference, but
> > i do have to mention we have quite a large repository directory (97
> > projects), this is structured as shown.
>
> > |-SVN:<serverip>
> > † |-<project 1>
> > † |-<project 2>
> > † |-<..>
> > † |-<..>
> > † |-<project 97>
>
> > any infomation you may be able to provide on this would be great, also
> > is there a way to reproduce this slowdown every time i open the repo
> > browser, as after the first initial slow connection every subsequent
> > load is really fast, and it would make testing any solutions you guys
> > offer a bit of a long process, if i have to wait 24 hours per test.
>
> Is the repository browser slow or your view in the explorer? Those are
> completely different things.
>
> Stefan
>
> --
> † † † † ___
> † †oo †// \\ † † †"De Chelonian Mobile"
> † (_,\/ \_/ \ † † TortoiseSVN
> † † \ \_/_\_/> † †The coolest Interface to (Sub)Version Control
> † † /_/ † \_\ † †http://tortoisesvn.net
>
> †signature.asc
> 1KDownload

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe_at_tortoisesvn.tigris.org
For additional commands, e-mail: users-help_at_tortoisesvn.tigris.org
Received on 2008-07-29 17:00:38 CEST

This is an archived mail posted to the TortoiseSVN Users mailing list.