[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: OK button unresponsive in "Lock Files" dialog box...

From: Tobias Schäfer <tobiasschaefer_at_gmx.de>
Date: 2007-02-05 22:10:28 CET

On Friday 02 February 2007 11:16, David Hedley wrote:
> If you right-click on a directory and select 'Get locks...', the 'OK'
> button is enabled several seconds before it is responsive - i.e. during
> this time, clicking it does nothing. After a few seconds you can click
> it and then the dialog goes away and everything works as expected. Could
> there be a problem with the timing of enabling this button?
>
> If you need any further details then please reply direct to me as I'm
> not on the mailing list.

Which TortoiseSVN version are you using?

I've tried reproducing this by calling "Get locks" on the rather large
repository of TortoiseSVN repository (without confirming the dialog :-) )
but cannot reproduce your use case. I'm using 1.4.3 and trunk.

The code looks straight forward and I cannot see an obvious bug, so could
you please give more details.

How many files are in the directory? How long do the single steps take? Does
this also happen if you call "Get locks..." on a directory with very few
files?

Tobias

-- 
       ___
  oo  // \\      "De Chelonian Mobile"
 (_,\/ \_/ \     TortoiseSVN
   \ \_/_\_/>    The coolest Interface to (Sub)Version Control
   /_/   \_\     http://tortoisesvn.net
---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tortoisesvn.tigris.org
For additional commands, e-mail: users-help@tortoisesvn.tigris.org
Received on Mon Feb 5 22:10:52 2007

This is an archived mail posted to the TortoiseSVN Users mailing list.