[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Repository Browser hangs when deleting directories from left hand pane

From: Stefan Küng <tortoisesvn_at_gmail.com>
Date: Tue, 23 Aug 2011 21:01:59 +0200

On 23.08.2011 09:48, Ryan J Ollos wrote:
> I've been meaning to put together a batch file to demonstrate this issue, but
> haven't gotten to it in the past month, so I'd thought it would be better to
> just throw it out and see if it can be resolved with the following
> information.
>
> * I'm accessing my repository over HTTPS
> * The issue occurs when deleting directories through the Repository
> Browser. This is the only situation that I've known this to occur, but I
> should also say that I hardly ever delete files through the Repository
> Browser. My group's procedure is to delete branches after reintegration to
> the trunk, so that is an operation I perform frequently and therefore I've
> encountered this issue many times.
>
> TSVN sometimes hangs when trying to delete a directory. I eventually have to
> kill TSVN and "send the error report", and the directory does not get
> deleted. However, this only happens sometimes. A factor that seems to
> correlate with whether TSVN will hang is whether the directory is deleted
> from the left hand pane or right hand pane of Repository Browser.
>
> Suppose I'm deleting `^/branches/mybranch`. If `mybranch` is selected in the
> left hand pane and I attempt to perform the delete operation from the left
> hand pane, TSVN seems to always hang. However, if `branches` is selected in
> the left hand pane and the delete operation is applied to `mybranch` in the
> right hand pane, TSVN will not hang.
>
> Here are two screen captures to demonstrate. TSVN WON'T hang when delete is
> invoked as shown in [1]. TSVN WILL hang when delete is invoked as shown in
> [2].
>
> If you are able to readily reproduce, I'll investigate further, but i've
> seen the issue at least a dozen times so I'm confident there are some
> conditions under which this problem is real.

Couldn't reproduce this, but I made a slight change in r21895 which
could fix the issue. Not sure though since I can't reproduce this.

Stefan

-- 
        ___
   oo  // \\      "De Chelonian Mobile"
  (_,\/ \_/ \     TortoiseSVN
    \ \_/_\_/>    The coolest Interface to (Sub)Version Control
    /_/   \_\     http://tortoisesvn.net
------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=757&dsMessageId=2828976
To unsubscribe from this discussion, e-mail: [dev-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2011-08-23 21:02:49 CEST

This is an archived mail posted to the TortoiseSVN Dev mailing list.