[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: windows explorer hangs

From: oyvind <oyvind.bjorlow_at_gmail.com>
Date: Mon, 18 May 2009 05:27:48 -0700 (PDT)

Background:
Tortoise SVN had a heavy negative impact on Explorer performance, lags
measured in tens of seconds, something I've never experienced in
years of Tortoise CVS usage.

Some notes from experiments in the last few days:
Disabling Nod32 (version 3.0 btw) had no effect
Uninstalling Groove had no effect (I considered that too many icon
overlays might cause problems)
hardcoding Include/Exclude paths in Tortoise SVN setup and terminating
tsvncache.exe (which caused a process restart) did speed up
performance.

Other notes on the system:
We've mounted up some shares as logical drives, o:\ v:\ etc.
I originally suspected there might be some slow network access to
those that contributed, however,
I didn't include them in the Exclude list, so network drives might not
have any impact after all.

Tortoise SVN version is currently 1.6.1.16129.

I've not had the time to get any mem dumps I'm afraid. Let me know if
it's really important and I'll try to get it done next weekend.
I'll probably also upgrade Tortoise SVN.

Oyvind

------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=757&dsMessageId=2299435

To unsubscribe from this discussion, e-mail: [dev-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2009-05-18 14:28:32 CEST

This is an archived mail posted to the TortoiseSVN Dev mailing list.