[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: commit hangs with hyperthreading

From: <mjohnston_at_austar.com.au>
Date: 2006-02-13 00:12:13 CET

I have a Dell Optiplex GX620 with Hyperthreading and have had no issues
here.

Regards,
_______________________________
Mark Johnston
IT Systems Development
Austar Communications Pty Ltd
w: http://www.austar.com.au
e: mjohnston@austar.com.au
p: 61 7 5560 6806
m: 61 417 726 718

 ------------------------------+------------------------------------------|
                               | |
                               | |
                    "Roman | To|
                    Korchagin" | <dev@tortoisesvn.tigris.org> |
                    <romeok@ros| cc|
                    vet.com> | |
                    13/02/2006 | Subject|
                    05:11 AM | commit hangs with |
                               | hyperthreading |
                            Ple| |
                            ase| |
                            res| |
                            pon| |
                             d | |
                            to | |
                            dev| |
                            @to| |
                            rto| |
                            ise| |
                            svn| |
                            .ti| |
                            gri| |
                            s.o| |
                            rg | |
                               | |
                               | |
                               | |
                               | |
                               | |
 ------------------------------+------------------------------------------|

I’ve upgraded my Pentium 4 2.4Ghz FSB 533Mhz (that had no hyperthreading)
to Pentium 4 3.0Ghz FSB 800Mhz that has hyperthreading and tortoisesvn
immediately started to hang on commit. This hang is reliably reproduced
when I commit more than 8-10 files. In fact, I simply cannot commit more
than 10 files – it always hangs. The commit window just stop responding.

I’m 100% sure it is related to hyperthreading since when I switch it off in
BIOS, commit for multiple files works okay. When I switch hyperthreading
on, the problem is again reproducible.

I’ve upgraded to 1.3.1 build 5521, the same behavior.

Regards,
Roman

=================================================================
This message has been scanned for viruses by AUSTAR Communications
antivirus and content checking applications.
-----------------------------------------
AUSTAR Communications
=================================================================

**********************************************************************
This email and any files transmitted with it are confidential and is
intended solely for the use of the individual or entity to whom they are
addressed. If you have received this email in error, please notify the system manager.

This footnote also confirms that this email message has been scanned by AUSTAR Communications content and virus scanning applications
for the presence of computer viruses.
**********************************************************************
Received on Mon Feb 13 00:13:00 2006

This is an archived mail posted to the TortoiseSVN Dev mailing list.