[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

[TSVN] [bug] unable to connect with wathever plink used

From: Emmanuel Coirier <manuco_at_club-internet.fr>
Date: 2005-09-14 00:23:29 CEST

Hello,

When trying to checkout some files from my perso repository with a fresh
installation of the latest tortoisesvn, there was some strange problems :

what you did :
I right-clicked on "make happy me.. hahem.

what you did :
I clicked the checkout option, then enter
svn+ssh://manu@192.168.1.1/var/svnrepository/
then clicked "..." to browse the repository

what you wanted to happen :
I wanted my repository displayed correctly, like on others machines.

what actually happened :
I heard an error notification sound, and nothing else was displayed.
Then I tried with the real plink, and an item showed me that the connection
was closed unexpectedly.

I have also PuTTY set up on the machine, with the default options set to
"telnet" (I don't know why and I don't care). In this case, plink tried to
connect with the telnet protocol (which is not running on the server), and
the connection failed.

So I have some suggestions :
- display a message when tortoiseplink failed for whatever reason ;
- add the -ssh option of plink (or do the modification in tortoiseplink that
enable this option) in order to force the ssh protocol, or an option in the
network option pane to select this feature ;
- perhaps add (if possible) in a corner a debug feature to see exchanges
between external programs and tortoisesvn, to quickly see where the problems
are (I spent two hours to discover that it was a PuTTY problem...)

I'm not subscribed to the list, so please CC me for answers, thanks.

best regards,

-- 
Emmanuel Coirier

  • application/pgp-signature attachment: stored
Received on Wed Sep 14 08:12:59 2005

This is an archived mail posted to the TortoiseSVN Dev mailing list.