[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [TSVN] Delay before update truly starts?

From: Jean-Marc van Leerdam <developer_at_bemy.demon.nl>
Date: 2005-05-27 21:55:00 CEST

Hi Simon,

> developer@bemy.demon.nl wrote:
>> Whenever I update my WC of TSVN (used for grabbing the Dutch .po's
>> and occasionally
>> peeking through the code) there is a significant delay between
>> showing the update dialog
>> (which appears 'instantly') and the interaction with the repository
>> (I can tell, because
>> ZoneAlarm doesn't ask for permission to let TSVN through until like
>> 10 to 15 seconds
>> later).

> I see this delay too with ZoneAlarm, but only when I upgrade TSVN so
> that it needs to update its permissions. When TSVN already has
> permission, the delays with TSVN and CLI are pretty much the same, and
> fairly short.

> It maybe a deliberate delay built into ZoneAlarm for some reason.
That's mean ;)

No, tonight the internal delay was small (even though I hadn't given
permanent permission for TSVN in ZoneAlarm yet). I think the 'problem'
lies in the fact that sometimes I have had HTTP traffic already (IE or
Firefox), and sometimes TSVN is the first one to start it. XP loading
stuff to handle the HTTP traffic may be the culprit here.

I'll keep an eye on it and report back if I can pinpoint the true
cause.

Regards,

Jean-Marc

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tortoisesvn.tigris.org
For additional commands, e-mail: dev-help@tortoisesvn.tigris.org
Received on Fri May 27 21:55:15 2005

This is an archived mail posted to the TortoiseSVN Dev mailing list.