[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [Subclipse-users] Unsupported Password Stores still a problem with Subversion 1.7?

From: Mark Phippard <markphip_at_gmail.com>
Date: Tue, 24 Apr 2012 08:32:02 -0400

The problem still exists with Subversion 1.7.

In the Subclipse preferences you can configure it to use a specific
folder for the Subversion configuration directory. You can use this
option if you want to be able to use GNOME keyring with the command
line client. But, you cannot use it with Subclipse as the Subversion
libraries will crash the JVM if you try to use it.

On Tue, Apr 24, 2012 at 7:55 AM, Nils Woetzel <nilswoetzel_at_web.de> wrote:
> My configuration
>
> Linux Ubuntu 10.10 x86_64
> eclipse 3.7.2
> subclispe 1.8.x
> subversion 1.7.4 (compiled on my own with gcc 4.7)
> SVN Team Provider Core 1.8.8 org.tigris.subversion.subclipse
>
> I have the following entry in /home/{user}/.subversion/config
>
> password-stores = gnome-keyring
>
> And I am receiving this message, when I start eclipse:
>
> "Unsupported password stores"
> "Subversion 1.6 contains a bug that causes eclipse to crash when
> Subversion tries to interact with the GNOME keyring via the Subversion
> JavaHL API..."
>
> I am not sure why this warning is emitted, since I am using subversion
> 1.7.4 (verified in Preferences->Team->SVN);
> I can ignore that warning, and I have no issues with the GNOME keyring
> password stores.
>
> I would suggest, that instead of check if the version is >=1.6 that it
> actually only checks if the version is equal 1.6.x.
> I hope somebody else can verify, that the GNOME keyring together with
> the JavaHL API does indeed work with subversion 1.7.x (I had no issues
> with 1.7.3 either).
>
> This discussion:
> http://subclipse.tigris.org/ds/viewMessage.do?dsForumId=1043&dsMessageId=2461694
>
> Does not indicate, how to reproduce the problem, I am not sure if
> there is anything else in regards to that bug.
>
> Thanks
> Nils
>
> ------------------------------------------------------
> http://subclipse.tigris.org/ds/viewMessage.do?dsForumId=1047&dsMessageId=2951451
>
> To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_subclipse.tigris.org].

-- 
Thanks
Mark Phippard
http://markphip.blogspot.com/
------------------------------------------------------
http://subclipse.tigris.org/ds/viewMessage.do?dsForumId=1047&dsMessageId=2951459
To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_subclipse.tigris.org].
Received on 2012-04-24 14:32:32 CEST

This is an archived mail posted to the Subclipse Users mailing list.