[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [Subclipse-users] Can't seem to get svnkit client to show up

From: Chris <shef31_at_yahoo.com>
Date: Tue, 25 Oct 2011 10:48:06 -0500

Unable to get javahl to work, I downgraded to subclipse 1.6.18 and
svnkit 1.3.5.7406.

Now I add an svn repository location, try to connect, and svnkit
properly pops up a dialog asking for ssh credentials. I fill in the
username, select "Use private key authentication", browse to my keyfile,
enter a passphrase, and click "Save information". Hit ok.

The dialog closes and reopens with "Use password authentication"
checked. No error messages, no other indication of what the problem
might be.

How do I debug this?

(Environment: 64 bit Windows, Eclipse Indigo, JDK 1.6)

On 10/24/2011 5:51 PM, Mark Phippard wrote:
> There is really mot much to do. Everything is on our update site.
>
> For Subclipse 1.6.x we include JavaHL + SVNKit on the update site.
>
> For Subclipse 1.8.x we include JavaHL. SVNKit will not support SVN
> 1.7 for a few months so it will not appear on the 1.8.x update site
> until then.
>
> Subclipse 1.8.x includes 32/64-bit JavaHL for Windows. So this has
> everything you need to just work.
>
> Subclipse 1.6.x only includes 32-bit JavaHL. If you run 32-bit
> Eclipse with a 32-bit JVM it will run fine. Unless you need a>4GB
> Heap for some reason, this is the fastest way to run Eclipse anyway.
> If you must use 64-bit then you need to have 64-bit JavaHL library in
> your PATH. Easiest way to do that is to install SlikSVN 64-bit client
> for 1.6 as it includes JavaHL.
>
>
> On Mon, Oct 24, 2011 at 6:13 PM, Chris<shef31_at_yahoo.com> wrote:
>> I've installed subclipse with all the options, but when I go to Window /
>> Preferences /Team / SVN / SVN Client Interface, only JavaHL shows up in
>> the dropdown, not svnkit.
>>
>> I went to the svnkit eclipse update site and installed it, but still
>> nothing.
>>
>> The answer on StackOverflow doesn't work:
>>
>> http://stackoverflow.com/questions/6730394/svnkit-with-subclipse-under-eclipse-indigo
>>
>> The reason I want svnkit is that it just works, and it's what I used on
>> previous versions of Eclipse. I'm pulling my hair out getting javahl
>> configured correctly.
>>
>> How do I get the svnkit client adapter installed?
>>
>> (Environment: Eclipse Indigo, 64 bit Windows 7)
>>
>> ------------------------------------------------------
>> http://subclipse.tigris.org/ds/viewMessage.do?dsForumId=1047&dsMessageId=2862522
>>
>> To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_subclipse.tigris.org].
>>
>
>
>

------------------------------------------------------
http://subclipse.tigris.org/ds/viewMessage.do?dsForumId=1047&dsMessageId=2863495

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_subclipse.tigris.org].
Received on 2011-10-25 17:48:29 CEST

This is an archived mail posted to the Subclipse Users mailing list.