[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

[Subclipse-users] Having version conflict troubles trying to install 1.4.x after uninstalling 1.6.x

From: David M. Karr <dk068x_at_att.com>
Date: Mon, 8 Mar 2010 11:15:48 -0800

Today I'm trying to set up Subclipse in place of Subversive, as I've
been unable to get help with the problems I'm having with Subversive.

I first installed the 1.6.x version, which was probably a mistake.
After I installed it and attempted a merge, I got an error that occurs
when using a > 1.5.x client against a 1.3.x server (yes, that's what our
server version is), which is "Attempt to add tree conflict that already
exists". I had gotten this with Subversive, so I'm familiar with it.
So, I then uninstalled all the Subclipse components and proceeded to try
to install the 1.4.x version, which should resolve this particular
problem.

After uninstalling 1.6.x and trying to install 1.4.x, the dependency
check failed with this:

----------------------
Cannot complete the install because of a conflicting dependency.
  Software being installed: Subversion Client Adapter - Required 1.5.3
(org.tigris.subversion.clientadapter.feature.feature.group 1.5.3)
  Software currently installed: CollabNet Merge Client 2.0.1
(com.collabnet.subversion.merge.feature.feature.group 2.0.1)
  Only one of the following can be installed at once:
    Subversion Client Adapter 1.6.8 (org.tigris.subversion.clientadapter
1.6.8)
    Subversion Client Adapter 1.5.3 (org.tigris.subversion.clientadapter
1.5.3)
  Cannot satisfy dependency:
    From: CollabNet Merge Client 2.0.1
(com.collabnet.subversion.merge.feature.feature.group 2.0.1)
    To: org.tigris.subversion.subclipse.core 1.6.6
  Cannot satisfy dependency:
    From: Subversion Client Adapter - Required 1.5.3
(org.tigris.subversion.clientadapter.feature.feature.group 1.5.3)
    To: org.tigris.subversion.clientadapter [1.5.3]
  Cannot satisfy dependency:
    From: SVN Team Provider Core 1.6.8
(org.tigris.subversion.subclipse.core 1.6.8)
    To: bundle org.tigris.subversion.clientadapter [1.6.0,1.7.0)
-------------------

I don't understand how to resolve this. When I go to
"Help"-"About"-"Installation Details", there are no entries beginning
with (or including) "subversion". However, when I go to the "Plug-Ins"
tab, I see "Subversion Client Adapter", version 1.6.8, in the list. So,
it's obviously there, but how do I uninstall it if there's nothing
referencing it in the "Installed Software" tab that I can uninstall?

------------------------------------------------------
http://subclipse.tigris.org/ds/viewMessage.do?dsForumId=1047&dsMessageId=2456642

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_subclipse.tigris.org].
Received on 2010-03-08 20:23:38 CET

This is an archived mail posted to the Subclipse Users mailing list.