[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

[Subclipse-users] Create branch workflow (UI) is confusing

From: Eddie Stanley <eddiewould_at_paradise.net.nz>
Date: Tue, 23 Feb 2010 14:07:50 -0800 (PST)

Hi,

Using the following software:

- Eclipse 3.4.2
- Subversion Client Adapter 1.6.7
- SVN Team Provider Core 1.6.7
- SVNKit Client Adapter 1.6.7

I find the functionality of "Team" => "Branch/Tag" to be confusing. The
wizard/workflow should allow a graphical means to select the copy-to location
(URL), without first creating the new location.

To reproduce:
-------------
I selected my project in the package explorer, then selected "Branch/Tag" from
the Team context menu. A dialog box appeared asking me to enter or select the
target URL for the copy. I clicked the "Select..." button.

It then brought up a generic "Repository Browser" dialog, showing the contents
of the root of my repository structure:

branches/
tags/
trunk/

I clicked on the "branches" folder, right-clicked and then selected "new remote
folder". I then typed in the name for the new remote folder, which resulted in
an SVN commit operation.

When I was returned to the first wizard, the SVN copy operation failed because
the remote location already exists.

I think probably using the default "Repository Browser" for selecting the
copy-to URL is not the right thing to do in this case.

Can anyone advise whether this has already been reported as an issue?

Regards,
Eddie Stanley

------------------------------------------------------
http://subclipse.tigris.org/ds/viewMessage.do?dsForumId=1047&dsMessageId=2451193

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_subclipse.tigris.org].
Received on 2010-02-24 00:12:16 CET

This is an archived mail posted to the Subclipse Users mailing list.