[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [Subclipse-users] uninstall subclipse 1.6 and install 1.2 or 1.4.5

From: kumaar <kumaar.us_at_gmail.com>
Date: Mon, 17 Aug 2009 14:21:55 -0700 (PDT)

Hi Mark,
Thanks for your quick response,
I get the following message, what would be the cause for it.
This client is too old to work with working copy '/blah/blah/blah'; please
get a newer
Subversion client".

Any clues?

Kumar

Mark Phippard-3 wrote:
>
> On Mon, Aug 17, 2009 at 9:31 AM, kumaar<kumaar.us_at_gmail.com> wrote:
>
>> I have unique problem with my eclipse.
>> My server has subversion 1.4.5 and when my PC has subclipse 1.6 which
>> comes
>> default with eclipse when we do updates.
>> Since my working copy has latest version and my server has older version,
>> i
>> cannot make any changes to working copy and its says " Please update the
>> server to latest version". Since i don't have a control to upgrade server
>> subversion to latest , i have only option is to degrade subclipse 1.2 or
>> 1.4,
>>
>> I am not getting an option "uninstall" for subclipse 1.6 .
>> Can some one help me,
>
> Any Subversion 1.x client can talk to any 1.x server and Subversion
> does not have an error message that says you must upgrade your server
> to the latest version. This just cannot happen.
>
> There should be no problem at all using a 1.6 client with a 1.4
> server. It is very common.
>
> A problem you can get is mixing SVN clients on the same workstation.
> Older SVN clients will not be able to read/recognize any working copy
> touched by a newer client. So if you use Subclipse 1.6.x (which will
> create a 1.6 working copy) you cannot use a 1.4/1.5 command line
> client with the same working copy.
>
> The server version does not matter though.
>
> --
> Thanks
>
> Mark Phippard
> http://markphip.blogspot.com/
>
> ------------------------------------------------------
> http://subclipse.tigris.org/ds/viewMessage.do?dsForumId=1047&dsMessageId=2384338
>
> To unsubscribe from this discussion, e-mail:
> [users-unsubscribe_at_subclipse.tigris.org].
>
>

-- 
View this message in context: http://www.nabble.com/uninstall-subclipse-1.6-and-install-1.2-or-1.4.5-tp25006805p25014428.html
Sent from the subclipse - users mailing list archive at Nabble.com.
------------------------------------------------------
http://subclipse.tigris.org/ds/viewMessage.do?dsForumId=1047&dsMessageId=2384532
To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_subclipse.tigris.org].
Received on 2009-08-17 23:22:08 CEST

This is an archived mail posted to the Subclipse Users mailing list.