[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [Subclipse-users] 1.6.2: Annotate with merge info has problems

From: David Rothenberger <daveroth_at_acm.org>
Date: Wed, 01 Apr 2009 11:54:06 -0700

On 4/1/2009 10:24 AM, Mark Phippard wrote:
> On Wed, Apr 1, 2009 at 12:41 PM, David Rothenberger <daveroth_at_acm.org> wrote:
>> When I do Show Annotation with "Include merged versions" check, the
>> results are incorrect for lines that were changed in a version from a
>> merge. When I do it without "Include merged versions", the results
>> appear correct.
>
> Are you saying the boolean appears reversed?

No. Sorry for being unclear.

When I do Annotate without the flag set, I get the correct annotations
ignoring merge information. When I do Annotate with the flag set, lines
are attributed to the wrong versions. Lines that were changed in a
version from a merge are always incorrect, but it appears that other
lines from versions not from a merge are also incorrect.

However, on further investigation, I find that the "svn blame -g" output
on this file from my command-line client is also messed up, so I guess
this isn't a problem with Subclipse.

Sorry for the noise.

-- 
David Rothenberger  ----  daveroth_at_acm.org
Machines take me by surprise with great frequency.
                 -- Alan Turing
------------------------------------------------------
http://subclipse.tigris.org/ds/viewMessage.do?dsForumId=1047&dsMessageId=1509788
To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_subclipse.tigris.org].
Received on 2009-04-01 20:54:32 CEST

This is an archived mail posted to the Subclipse Users mailing list.