[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [Subclipse-users] Eclipse 3.4 gives "Unable to load default SVN Client"

From: Mika Laitio <lamikr_at_pilppa.org>
Date: Mon, 30 Mar 2009 13:43:54 +0300 (EEST)

>> We all have this tendency to want the 'latest and greatest'(me too). I
>> kept getting the same error on an up-to-date Ubuntu 8.10 linux(Intrepid
>> Ibex) but I kept trying to use the 1.6 version. When I got the software
>> and components from the http://subclipse.tigris.org/update_1.4.x site it
>> started working.
>>
>
> I had the exact same issue on a newly installed 3.4.2 on a 32-bit Vista
> machine. 0.7 and 1.6 would not recognize any adapters I loaded. Once I
> went back to http://subclipse.tigris.org/update_1.4.x , everything was
> happy. Thank you for posting this - I was going crazy trying to get it to
> run at all...

This is only partially true at least in my case.
Because I updated my Mandriva to newer version, I got 1.6.0
version of subversion and libsvnjavahl-1 library.

Once I got my original (mandriva bug in the libsvnjavahl-1 library
install) fixed, also the subclipse 1.6.0 started working ok.

But if I used another eclipse 3.4 instance which had plugins from the
subclipse-1.4.x branch, then the commands like "show history" in the java
or c++ perspectives crashed.

So it seems that libsvnjavahl libraries are not backward compatible.
(and they start use numbering instead of claiming that the library version
is always 0.0.0, like libsvnjavahl-1.so.0.0.0)

Mika

------------------------------------------------------
http://subclipse.tigris.org/ds/viewMessage.do?dsForumId=1047&dsMessageId=1480628

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_subclipse.tigris.org].
Received on 2009-03-30 14:33:54 CEST

This is an archived mail posted to the Subclipse Users mailing list.