[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

[Subclipse-users] Mysterious JavaHL

From: <webpost_at_tigris.org>
Date: Mon, 16 Mar 2009 13:38:17 -0700 (PDT)

I'm currently running CentOS 5.2, x64, along with Eclipse 3.4 and Subclipse 1.4. I'm also using Sun's JDK 1.6.12.

I just installed a clean Eclipse Classic (3.4) and the latest Subclipse 1.4 from the update site.

Since CentOS 5.2 does not include Subversion 1.5+, nor does it include JavaHL bindings, I had to compile Subversion from source.

I built a custom RPM, and the JavaHL bindings were installed successfully.

The only time Eclipse correctly displays the SVN interface as "JavaHL (JNI) 1.5.6.." is when I use a brand new workspace, that hasn't been created yet. As soon as I close Eclipse and re-open the newly created workspace, Eclipse goes back to reporting "JavaHL (JNI) Not Available"

Any hints on how to get this to work permanently?

I've been using SVNKit as the sole workaround to this issue.

------------------------------------------------------
http://subclipse.tigris.org/ds/viewMessage.do?dsForumId=1047&dsMessageId=1335270

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_subclipse.tigris.org].
Received on 2009-03-16 21:40:09 CET

This is an archived mail posted to the Subclipse Users mailing list.