[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [Subclipse-users] Subclipse cant handle [ ] characters ??

From: Mark Phippard <markphip_at_gmail.com>
Date: Wed, 10 Dec 2008 15:12:50 -0500

Sorry, forgot to reply to last message.

There is nothing you can do, aside from submit a patch. If it does
not work then it is a bug somewhere.

What is the exact reproduction scenario? You said you are using the
History option. Is it from a working copy or the repository view.
etc..

Mark

On Wed, Dec 10, 2008 at 3:09 PM, Bharat Khatri
<bkhatri9_at_rockwellcollins.com> wrote:
>
> What can I do in Subclipse to resolve this issue ?
>
> On Tue, Dec 9, 2008 at 11:41 AM, Bharat Khatri
> <bkhatri9_at_rockwellcollins.com> wrote:
>>
>> I have a file in my SVN repository with name that contains [ ] characters.
>> When trying to see the version history of the file from Eclipse, I get the
>> error:
>>
>> Bad URL passed to RA layer
>> svn: URL 'http://asvn/sandbox/trunk/prep_test/Testing[1].txt' is malformed
>> or the scheme or host or path is missing
>>
>> I can access the same file using Internet Explorer as well as see the
>> version history using TortoiseSVN.
>>
>> Do I need to do something special to make this work in Subclipse ?
>
> In your preferences under Team > SVN are you using JavaHL or SVNKit?
> The SVN provider should be converting the URL to a proper URL format.
>
> --
> Thanks
>
> Mark Phippard
> http://markphip.blogspot.com/
>
>
>
>
>
> Mark Phippard <markphip_at_gmail.com>
>
> 12/09/2008 10:44 AM
>
> Please respond to
> users <users_at_subclipse.tigris.org>
> To
> users_at_subclipse.tigris.org
> cc
> Subject
> Re: [Subclipse-users] Subclipse cant handle [ ] characters ??
>
>
>
>
> On Tue, Dec 9, 2008 at 11:41 AM, Bharat Khatri
> <bkhatri9_at_rockwellcollins.com> wrote:
>>
>> I have a file in my SVN repository with name that contains [ ] characters.
>> When trying to see the version history of the file from Eclipse, I get the
>> error:
>>
>> Bad URL passed to RA layer
>> svn: URL 'http://asvn/sandbox/trunk/prep_test/Testing[1].txt' is malformed
>> or the scheme or host or path is missing
>>
>> I can access the same file using Internet Explorer as well as see the
>> version history using TortoiseSVN.
>>
>> Do I need to do something special to make this work in Subclipse ?
>
> In your preferences under Team > SVN are you using JavaHL or SVNKit?
> The SVN provider should be converting the URL to a proper URL format.
>
> --
> Thanks
>
> Mark Phippard
> http://markphip.blogspot.com/
>
> ------------------------------------------------------
> http://subclipse.tigris.org/ds/viewMessage.do?dsForumId=1047&dsMessageId=981739
>
> To unsubscribe from this discussion, e-mail:
> [users-unsubscribe_at_subclipse.tigris.org].
>
>

-- 
Thanks
Mark Phippard
http://markphip.blogspot.com/
------------------------------------------------------
http://subclipse.tigris.org/ds/viewMessage.do?dsForumId=1047&dsMessageId=982516
To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_subclipse.tigris.org].
Received on 2008-12-10 21:13:38 CET

This is an archived mail posted to the Subclipse Users mailing list.