[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [Subclipse-users] Symbolic link with space in filename is not stored properly: BUG?

From: Jens Seidel <jensseidel_at_users.sourceforge.net>
Date: Wed, 17 Sep 2008 14:00:40 +0200

On Wed, Sep 17, 2008 at 11:24:11AM +0200, Hendrik Maryns wrote:
> I have a project which contains a symbolic link to a file in another
> project which is also in the repo. The filename contains a space and
> the link has the same name. Now the file itself is checked out properly
> in the one project, but the link contains only *the last part of* the
> symbolic link, i.e. the part after the space in the filename.
>
> This seems like a bug to me.
>
> What to do here?

Now you tell us your version of Subversion and Subclipse :-) Do you use
JavaHL or SVNKit?

Can you reproduce it on the command line? It should not be very difficult.
If yes, it's a bug in Subversion. I think I remember reading about a
similar issue the last weeks (or months), so maybe it is already fixed.

Just try to reproduce and I can test whether Subversion trunk is
affected as well.

Maybe it's also a bug in Subclipse ...

Jens

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe_at_subclipse.tigris.org
For additional commands, e-mail: users-help_at_subclipse.tigris.org
Received on 2008-09-17 14:13:39 CEST

This is an archived mail posted to the Subclipse Users mailing list.