[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [Subclipse-users] Problem with javahl libraries

From: Rune V. Sjøen <rvsjoen_at_gmail.com>
Date: Tue, 13 May 2008 16:52:47 +0200

>
> > And if I run ldconfig -v, the library in /usr/lib is also listed
> >
> > and I am not able to run java applications that use javahl bindings,
> even if
> > the library path is set correctly
> > I also tried setting LD_LIBRARY_PATH before invoking the applications.
>
> Are all used libraries in libsvnjavahl-1.so found? Start ldd on it to
> verify!

ldd /usr/local/lib/libsvnjavahl-1.so
        libstdc++.so.5 => /usr/lib/libstdc++.so.5 (0x00693000)
        libsvn_repos-1.so.0 => /usr/local/lib/libsvn_repos-1.so.0
(0x00292000)
        libsvn_client-1.so.0 => /usr/local/lib/libsvn_client-1.so.0
(0x00eba000)
        libsvn_wc-1.so.0 => /usr/local/lib/libsvn_wc-1.so.0 (0x007c8000)
        libsvn_ra-1.so.0 => /usr/local/lib/libsvn_ra-1.so.0 (0x00552000)
        libsvn_delta-1.so.0 => /usr/local/lib/libsvn_delta-1.so.0
(0x00611000)
        libsvn_subr-1.so.0 => /usr/local/lib/libsvn_subr-1.so.0 (0x00dd0000)
        libaprutil-0.so.0 => /usr/local/apr/lib/libaprutil-0.so.0
(0x00111000)
        libexpat.so.0 => /usr/local/apr/lib/libexpat.so.0 (0x00124000)
        libapr-0.so.0 => /usr/local/apr/lib/libapr-0.so.0 (0x00a83000)
        librt.so.1 => /lib/tls/librt.so.1 (0x00911000)
        libm.so.6 => /lib/tls/libm.so.6 (0x0078e000)
        libcrypt.so.1 => /lib/libcrypt.so.1 (0x0013f000)
        libnsl.so.1 => /lib/libnsl.so.1 (0x0016c000)
        libpthread.so.0 => /lib/tls/libpthread.so.0 (0x00cbf000)
        libdl.so.2 => /lib/libdl.so.2 (0x005f7000)
        libz.so.1 => /usr/lib/libz.so.1 (0x00e7b000)
        libc.so.6 => /lib/tls/libc.so.6 (0x002ad000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x00181000)
        libsvn_fs-1.so.0 => /usr/local/lib/libsvn_fs-1.so.0 (0x001d0000)
        libsvn_diff-1.so.0 => /usr/local/lib/libsvn_diff-1.so.0 (0x0018a000)
        libsvn_ra_local-1.so.0 => /usr/local/lib/libsvn_ra_local-1.so.0
(0x0076f000)
        libsvn_ra_svn-1.so.0 => /usr/local/lib/libsvn_ra_svn-1.so.0
(0x00190000)
        libsvn_ra_dav-1.so.0 => /usr/local/lib/libsvn_ra_dav-1.so.0
(0x0019f000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x00883000)
        libsvn_fs_fs-1.so.0 => /usr/local/lib/libsvn_fs_fs-1.so.0
(0x001d5000)

It does look like all the dependencies are met

>
>
> Jens
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe_at_subclipse.tigris.org
> For additional commands, e-mail: users-help_at_subclipse.tigris.org
>
>

-- 
Rune V. Sjoen
You always pass failure on the way to success
Received on 2008-05-13 16:53:04 CEST

This is an archived mail posted to the Subclipse Users mailing list.