[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

RE: [Subclipse-users] Subclipse is not recognizing modifications anymore

From: Deb Lewis <djlewis_at_acm.org>
Date: 2006-06-27 06:39:46 CEST

Nils - what platform are you running on? If you're on Windows XP and using
the ZoneAlarm Pro firewall, check/update your firewall IMMEDIATELY to the
latest version (6.5.722, released over the weekend).

Took me nearly a week of increasing bafflement and aggravation to track this
problem back to its source in ZoneAlarm on my system. Apparently the
version of ZAP released in early June broke the file timestamp updating on
changed files edited in at least applications, notably eclipse, so while you
could happily edit in eclipse the underlying file timestamp didn't get
updated. The problem was reported on ZoneAlarm user forums in early June
and wasn't fixed for nearly 2 weeks.

So anything relying of file timestamps was effectively broken: subclipse
change detection, time-dependent build processes (only recompile or deploy
if changed...), etc.

Deb Lewis

-----Original Message-----
From: Nils Lindenberg [mailto:nils.lindenberg@gmail.com]
Sent: Sunday, June 25, 2006 9:27 AM
To: users@subclipse.tigris.org
Subject: [Subclipse-users] Subclipse is not recognizing modifications
anymore

Hello,

I have used subclipse for about three month, without a problem. When I
changed a file, there was a * in the navigator indicating that it had been
changed. Three days ago (and I can't remember to have changed any
setting) this has stopped:

When I change a file now, there is no * in the navigator view and I can't
submit a file to the repository. If I use "Compare with latest from
Repository" it tells me that there are no changes between the files, even if
I have deleted half of the content. "Compare with base revision" tells me
the same. Only "Compare with local history" works as expected.

Can somebody tell me, what is wrong? I did a fresh install of Eclipse,
phpeclipse and subclipse + a new checkout, but that did not help

Eclipse: Version: 3.1.2
(phpEclipse: 1.1.8)
Subclipse: 1.0.3

Thanks in advance,

Nils Lindenberg

---------------------------------------------------------------------

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subclipse.tigris.org
For additional commands, e-mail: users-help@subclipse.tigris.org
Received on Tue Jun 27 06:40:06 2006

This is an archived mail posted to the Subclipse Users mailing list.