[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

[Subclipse-users] svnant causes a "Bus error"

From: Daniel Smith <dlsmith_at_rice.edu>
Date: 2006-03-09 20:55:57 CET

Updating javahl.jar did the trick. Thanks for your help -- I'm not
sure I ever would have figured out what was going wrong without you.

To summarize:
- svnAnt will only work out of the box with Subversion 1.2.* (unless
I disable javahl, perhaps?)
- If I intend to use my modified 1.3-compatible svnAnt in my build
scripts (by bundling the svnAnt libs in my source repository), all
developers working with the code must have Subversion 1.3.* clients.

Is that correct?

óDan

> Looking at those Google results it seems to be related to an error in
> native code.
>
> svnAnt requires JavaHL 1.2, not 1.3. And you do get a native code
> error if
> you mix them. If possible see if you can downgrade to 1.2.
> Otherwise, try
> updating the svnjavahl.jar file to the one from Subversion 1.3. I
> think
> that will also work. You can pull a copy of that JAR from our
> repository:
>
> http://subclipse.tigris.org/svn/subclipse/trunk/subclipse/core/lib/
>
> Login with guest/guest if needed.
>
> Mark

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subclipse.tigris.org
For additional commands, e-mail: users-help@subclipse.tigris.org
Received on Thu Mar 9 20:56:17 2006

This is an archived mail posted to the Subclipse Users mailing list.