[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: subclipse not recognizing managed project FIXED (Was: [ANN] JavaSVN v0.8.8 - broke my working copies?)

From: Hugo Visser <hugo_at_botteaap.net>
Date: 2005-04-21 23:41:49 CEST

Even more simple fix: tell eclipse the "correct" path when using switch
workspace: D:\Code\Java\eclipse\workspace works but all in lowercase
fails. That would explain things, I might have changed workspaces one
time...(and I always type the paths :))

Hugo Visser wrote:
> Okay, the thing I've found out now that my projects are recognized only
> if the workspace is on my C:\ drive. They used to be on my D: drive. I
> don't understand it but I can reproduce it.
>
> First I checked out the failing project to the workspace dir on D:\
> using the cli. Then I imported the project in Eclipse, but SVN did not
> recognized it. Then I did the same, checking the project out to my C:\
> drive. That worked. Also checking out from within Eclipse works when it
> is on C:\
>
> While I'm typing this mail I realize Ian's tip about capitalization. My
> workspace on D:\ is in D:\Code\Java\eclipse\workspace (note the capital
> C and J). So I tried again checking out in D:\test. That works. Check it
> out again in D:\Test --> Fail!
>
> So is this a known subclipse issue or is it a subversion issue? Ian is
> this what you meant? I think I did not get the hint entirely when you
> mentioned it. Thanks anyway for that. So I guess my workaround will be
> to put the workspace in a different path. Still I don't get why it has
> worked before. Anyway, I'm happy that it does now :)
>
> Hugo
>
> Hugo Visser wrote:
>
>> Jan,
>>
>> Did you try different Eclipse versions? I'll try to go back a few
>> subclipse versions. Subclipse did work here so somewhere it got broken!
>>
>> Hugo
>>
>>>
>>> Hello,
>>>
>>> I reported the same problem a while ago here - it happens for me
>>> under Linux with Eclipse 3.0.2, Subclipse 0.9.30 and JavaSVN 0.8.7,
>>> as well as 0.8.8.1 There seems to be no known solution or workaround.
>>>
>>> Best regards -
>>> Jan Ploski
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: users-unsubscribe@subclipse.tigris.org
>>> For additional commands, e-mail: users-help@subclipse.tigris.org
>>>
>>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: users-unsubscribe@subclipse.tigris.org
>> For additional commands, e-mail: users-help@subclipse.tigris.org
>>
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@subclipse.tigris.org
> For additional commands, e-mail: users-help@subclipse.tigris.org
>
>
Received on Fri Apr 22 07:41:49 2005

This is an archived mail posted to the Subclipse Users mailing list.