[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Broken version for Mac OS X?

From: Dan North <dan_at_tastapod.com>
Date: 2005-02-15 19:02:52 CET

Mark, thank you thank you thank you.

1) add line to /etc/apt/sources.list
2) apt-get install subversion/unstable && apt-get install libsvn-javahl
3) there is no step three :)

So now I'm back using my ssh key for svn+ssh - woohoo!

Did I mention thank you?

--
Dan
On Tuesday 15 February 2005 16:13, Mark Phippard wrote:
> See if this helps:
>
> http://svn.haxx.se/users/archive-2005-01/1473.shtml
>
> Mark
>
> Dan North <dan@tastapod.com> wrote on 02/15/2005 11:05:58 AM:
> > Has anyone created a .deb of javahl 1.1.3? And if they have would they
>
> be
>
> > interested in sharing it with me? :)
> >
> > For some reason the tarball gremlins still hate me.
> >
> > Thanks,
> > Dan
> >
> > On Tuesday 15 February 2005 15:37, Mark Phippard wrote:
> > > Arvid Warnecke <arvid.warnecke@gutzmann.com> wrote on 02/15/2005
>
> 10:32:29
>
> > > AM:
> > > > I just recognized that the up-to-date version of subclipse does not
> > > > seem to work for Eclipse on OS X anymore.
> > > > When I try to open the preferences for SVN in Eclipse I get the
>
> message:
> > > > "Unable to create the selected preferences page.
> > > > Reason:
> > > > Plug-in org.tigris.subversion.subclipse.ui was unable to load class
> > > > org.tigris.subversion.subclipse.ui.preferences.SVNPreferencesPage."
> > > >
> > > > Errors like that come up, when I try to change to the SVN Repository
> > > > View.
> > > >
> > > > I tried the plugin on a windows machine and it worked fine. I also
> > > > tried to add the plugin to a fresh eclipse on OS X, but I still get
>
> the
>
> > > > same error messages.
> > >
> > > That error message tends to happen when Subclipse cannot instantiate
> > > either the JavaHL adapter ot the Command Line adapter.
> > >
> > > In the latest Subclipse, we included the latest version of the JavaHL
>
> JAR
>
> > > file that corresponds to Subversion 1.1.3.  My best guess would be
>
> that
>
> > > you have an older version of Subversion JavaHL library installed so
>
> that
>
> > > JAR file will not load the library.
> > >
> > > If possible, install Subversion from the Metissian packages.
> > >
> > > http://metissian.com/projects/macosx/subversion/
> > >
> > > Another alternative, would be to replace the version of svnjavahl.jar
>
> in
>
> > > the Subclipse core plugin, with a version of the JAR suitable for your
> > > version of JavaHL.  You could probably just copy the version of the
>
> JAR
>
> > > that was installed with the last working version of the plugin.
> > >
> > > You might need to start Eclipse with the -clean option after making
>
> that
>
> > > change.
> > >
> > > Mark
>
> ___________________________________________________________________________
>
> > >__ Scanned for SoftLanding Systems, Inc. by IBM Email Security
>
> Management
>
> > > Services powered by MessageLabs.
>
> ___________________________________________________________________________
>
> > >__
> > >
> > > ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: users-unsubscribe@subclipse.tigris.org
> > > For additional commands, e-mail: users-help@subclipse.tigris.org
> >
> > --
> > --
> > Dan North
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: users-unsubscribe@subclipse.tigris.org
> > For additional commands, e-mail: users-help@subclipse.tigris.org
>
> ___________________________________________________________________________
>__
>
> > Scanned for SoftLanding Systems, Inc. by IBM Email Security Management
> > Services powered by MessageLabs.
>
> ___________________________________________________________________________
>__
>
>
> ___________________________________________________________________________
>__ Scanned for SoftLanding Systems, Inc. by IBM Email Security Management
> Services powered by MessageLabs.
> ___________________________________________________________________________
>__
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@subclipse.tigris.org
> For additional commands, e-mail: users-help@subclipse.tigris.org
-- 
--
Dan North
Received on Wed Feb 16 05:02:52 2005

This is an archived mail posted to the Subclipse Users mailing list.