[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

subclipse error when i try to commit

From: Aadi Deshpande <mailinglists_at_clubmom-inc.com>
Date: 2004-12-28 18:44:09 CET

I checked out a working copy from a subversion repository using
subclipse and for some reason i keep getting this error :

org.tigris.subversion.javahl.ClientException:
home/aadid/workspace/ROOT/promotions/fit does not contain working copy files
org.tigris.subversion.svnclientadapter.SVNClientException:
org.tigris.subversion.javahl.ClientException:
home/aadid/workspace/ROOT/promotions/fit does not contain working copy files
org.tigris.subversion.svnclientadapter.javahl.JhlClientAdapter.commit(JhlClientAdapter.java:196)
org.tigris.subversion.subclipse.core.commands.CheckinResourcesCommand$1.run(CheckinResourcesCommand.java:94)
org.tigris.subversion.subclipse.core.SVNProviderPlugin$5.run(SVNProviderPlugin.java:399)
org.eclipse.core.internal.resources.Workspace.run(Workspace.java:1673)
org.eclipse.core.internal.resources.Workspace.run(Workspace.java:1693)
org.tigris.subversion.subclipse.core.SVNProviderPlugin.run(SVNProviderPlugin.java:394)
org.tigris.subversion.subclipse.core.commands.CheckinResourcesCommand.run(CheckinResourcesCommand.java:83)
org.tigris.subversion.subclipse.core.SVNTeamProvider.checkin(SVNTeamProvider.java:105)
org.tigris.subversion.subclipse.ui.operations.CommitOperation.execute(CommitOperation.java:63)
org.tigris.subversion.subclipse.ui.operations.SVNOperation.run(SVNOperation.java:90)
org.eclipse.team.internal.ui.actions.JobRunnableContext.run(JobRunnableContext.java:159)
org.eclipse.team.internal.ui.actions.JobRunnableContext$3.runInWorkspace(JobRunnableContext.java:179)
org.eclipse.core.internal.resources.InternalWorkspaceJob.run(InternalWorkspaceJob.java:38)
org.eclipse.core.internal.jobs.Worker.run(Worker.java:66)

I tried to use the command line and java-svn ( i can't use javahl for a
myriad of reasons ), but the same error occurs.

it seems as though the leading slash in /home is mssing.

how do i get it back?

TIA,
-a
Received on Wed Dec 29 04:44:09 2004

This is an archived mail posted to the Subclipse Users mailing list.