[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: problems with non US locale

From: Wolfgang Fritz <wolfgang.fritz_at_keymile.com>
Date: 2004-10-25 08:38:29 CEST

Henning Westerholt wrote:
> Hello list,
>
> i┤m using the latest subclipse with svn-1.1.0 on eclipse 3.0.1. After the
> upgrade to svn1.1.0, the subclipse plugin stop allmost working.
>
> The reason:
> The new subversion contain localized error and status messages. If i start
> eclipse with locale "de_DE@euro", i got the following error messages in the
> c++ browsing interface:
>
> Exception in Decorator
> Reason:
> String index out of range: -1
> Unhandled event loop exception
> Reason:
> java.lang.NullPointerException
> [...]
>
> After i set the locale to "en_US", everything works as expected. Subclipse
> fails also to parse the local dates in the svn repository browsing view:
>
> java.text.ParseException: Unparseable date: "Okt 24 22:3"
> at java.text.DateFormat.parse(DateFormat.java:335)
> at
> org.tigris.subversion.svnclientadapter.commandline.CmdLineRemoteDirEntry.<init>
> (CmdLineRemoteDirEntry.java:126)
> at org.tigris.subversion.svnclientadapter.commandline.CmdLineClientAdapter.
> getList(CmdLineClientAdapter.java:232)
> [...]
>
> For now i set the proper locale in the eclipse startup script.
> Perhaps it is possible to move this setting into the subclipse code?
> (Sorry for my report if this is a known issue.)
>

I have 2 workstations with in my opinion identical setups (Linux SuSE
9.0). On one system I get these errors, on the other system it's working
fine. The locale on both machines is de_DE@euro. I double checked the
installation on both machines but could not find any diferrences.

This problem ocuured after I did an upgrade of both subversion and
subclipse (on both machines, of course).

Wolfgang

> Best regards,
>
> Henning
Received on Mon Oct 25 16:38:29 2004

This is an archived mail posted to the Subclipse Users mailing list.