[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: libsvnjavahl with 0.9.21 on linux - help

From: Aaron Digulla <digulla_at_hepe.com>
Date: 2004-10-06 00:03:34 CEST

Alwyn Schoeman wrote:
> Tried to strace eclipse, but it is not working.
>
> I have a /usr/lib/libsvnjavahl-1.so in /usr/lib. ldconfig lists it as
> being in the system
> path.
>
> I run eclipse from a shell script. It is the only way I have found to
> use it as a panel shortcut. Can this be the problem?

Try my step-by-step guide. Does the make check-javahl work?

I've found that with my first attempt, it created a *.so but there were
missing symbols so Java couldn't load it. Only then this works, try to load it
eclipse because then, you won't get any errors when it cannot be loaded.

On a related note: It would be great if subclipse would write an error into
the Eclipse log when javahl can't be loaded. It would make tracing that error
much easier.

-- 
Aaron "Optimizer" Digulla a.k.a. Philmann Dark
"It's not the universe that's limited, it's our imagination.
Follow me and I'll show you something beyond the limits."
http://www.philmann-dark.de/
Received on Wed Oct 6 08:03:34 2004

This is an archived mail posted to the Subclipse Users mailing list.