[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

[Subclipse-dev] Subclipse 1.6.0 release for Subversion 1.6 RC

From: Mark Phippard <markphip_at_gmail.com>
Date: Tue, 24 Feb 2009 13:31:30 -0500

Subversion 1.6.0 RC2 was released on Friday. One of the big features
in this release is something called "tree conflicts". Basically,
think of what happens if you have made local edits to a file and you
do an update and someone else has renamed this file. There are a lot
of variations on this scenario, but that gives the gist. In SVN 1.5
and earlier, Subversion is very silent when this happens. It pulls in
the new changes, and often just unversions your local edits. Starting
with 1.6, this now raises a new kind of conflict called a tree
conflict.

Subclipse 1.6.0 contains a lot of new work to first show you these
conflicts in the UI and second to help you work with them and resolve
them. A new Tree Conflicts view has been created to see them, of
course you can also see them in the decorators. But since tree
conflicts can occur on deleted items, we could not rely on decorators
alone. Also the view shows a little summary of what type of tree
conflict it is.

There is also a resolve option that will launch a wizard specific to
the scenario you are facing to help you resolve the conflict.

Subclipse 1.6.0 requires Subversion 1.6.0 JavaHL. SVNKit is not
currently supported as it does not yet support the 1.6 API's. We are
shipping a "dummy" SVNKit plugin to satisfy version requirements and
allow you to install.

As always, we include the binaries for Windows. CollabNet has an RPM
for Linux that includes JavaHL and an OSX binary will be posted soon.

http://www.open.collab.net/downloads/subversion/rc/

You can follow the instructions in this FAQ to see how to enable JavaHL:

http://subclipse.tigris.org/wiki/JavaHL

Subversion 1.6.0 will upgrade the format of your WC. Once this is
done, you will not be able to use it with a SVN 1.5 or earlier client.

NONE of the features in SVN 1.6 require your server to be running SVN
1.6 to use them. There were, of course, features added in SVN 1.5
that require a 1.5 server and still do, but the new 1.6 features like
tree conflicts do not.

The Subversion 1.6 release notes are a Work In Progress but can be seen here:

http://subversion.tigris.org/svn_1.6_releasenotes.html

OK, enough already how do you get it?

Update Site URL: http://subclipse.tigris.org/update_1.6.x
Changelog: http://subclipse.tigris.org/subclipse_1.6.x/changes.html

Eclipse 3.2 and higher are supported.

I will continue to backport fixes to the 1.4.x releases for a while,
and the 1.4.x release will stay on Subversion 1.5 support. A
Subversion 1.5.6 release is coming soon, and I plan to do a new 1.4.x
release at that time.

-- 
Thanks
Mark Phippard
http://markphip.blogspot.com/
------------------------------------------------------
http://subclipse.tigris.org/ds/viewMessage.do?dsForumId=1043&dsMessageId=1221836
To unsubscribe from this discussion, e-mail: [dev-unsubscribe_at_subclipse.tigris.org].
Received on 2009-02-24 19:31:43 CET

This is an archived mail posted to the Subclipse Dev mailing list.