[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: r1823791 - /subversion/trunk/Makefile.in

From: Daniel Shahaf <d.s_at_daniel.shahaf.name>
Date: Sat, 10 Feb 2018 19:47:44 +0000

stsp_at_apache.org wrote on Sat, 10 Feb 2018 19:26 +0000:
> +++ subversion/trunk/Makefile.in Sat Feb 10 19:26:03 2018
> @@ -872,9 +872,7 @@ $(SWIG_PL_DIR)/native/Makefile: $(SWIG_P
> -swig-pl_DEPS = autogen-swig-pl libsvn_swig_perl \
> - $(SWIG_PL_DIR)/native/Makefile
> -swig-pl: $(swig-pl_DEPS)
> +swig-pl: autogen-swig-pl $(SWIG_PL_DIR)/native/Makefile
> if test "`$(READLINK_PL) $(SWIG_PL_DIR)`" != "`$(READLINK_PL) $(SWIG_PL_SRC_DIR)`"; then \
> for f in $(SWIG_PL_SRC_DIR)/native/*.c ; do \
> if [ -e "$$f" ] ; then \

Is the removal of swig-pl_DEPS correct?

foo_DEPS appears to be a build.conf / build-outputs.mk naming convention:

% ag DEPS build | me
build/generator/templates/build-outputs.mk.ezt:29:[modules.name]_DEPS =[for modules.deps] [modules.deps][end]
build/generator/templates/build-outputs.mk.ezt:103:[target.varname]_DEPS = $([target.varname]_HEADERS) $([target.varname]_OBJECTS)[for target.add_deps] [target.add_deps][end][for target.deps][if-index target.deps first][else] [end][target.deps][end]
build/generator/templates/build-outputs.mk.ezt:104:[target.name]: $([target.varname]_DEPS)
build/generator/templates/build-outputs.mk.ezt:114:[else][is target.type "i18n"][target.varname]_DEPS =[for target.add_deps] [target.add_deps][end][for target.objects] [target.objects][end][for target.deps] [target.deps][end]
build/generator/templates/build-outputs.mk.ezt:115:[target.name]: $([target.varname]_DEPS)
build/generator/templates/build-outputs.mk.ezt:116:[else][target.varname]_DEPS =[for target.add_deps] [target.add_deps][end][for target.objdeps] [target.objdeps][end][for target.deps] [target.deps][end]
build/generator/templates/build-outputs.mk.ezt:118:[target.filename]: $([target.varname]_DEPS)

I suspect that removing swig-pl_DEPS this way is actually an improvement since
the assignment in Makefile.in would have conflicted with any possible (future)
assignment in build-outputs.mk, but I'm not entirely sure.

Presumably, if build-outputs.mk ever contains a definition of swig-
pl_DEPS it will also generate a 'swig-pl: $(swig-pl_DEPS)' line.

Cheers,

Daniel
Received on 2018-02-10 20:47:50 CET

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.