[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

RE: Problem with 'svn ls' in 1.7-pre with older servers

From: Bert Huijben <bert_at_qqmail.nl>
Date: Fri, 5 Aug 2011 23:17:02 +0200

                Hi,

 

Ok, I found and fixed this regression in ra_serf (r1154278, r1154379, r1154382).

 

This issue will occur for any repository older than 1.4.0.

 

(Current workaround is switching to neon. In your case the TSVN project already implemented that choice)

 

The fix for this problem is nominated for backport to 1.7, but was committed after creating the beta3 snapshot which is currently being tested.

 

                Bert

 

From: LIL. - Lilienthal, Benjamin [mailto:B.Lilienthal_at_skeye.com]
Sent: woensdag 27 juli 2011 12:39
To: dev_at_subversion.apache.org
Subject: Problem with 'svn ls' in 1.7-pre with older servers

 

Hi together,

 

we have problem using the nightly build of TSVN and it looks like an error in the 1.7-pre of subversion.

 

What I did:
-----------

I'd use the 'svn ls' command on our internal repositories.

 

 

What happens:
-------------

The following error happens: "svn: E200004: Could not convert '' into a number"

 

 

Information about our environment:
--------------------‚Äč--------------
TSVN Client-Version:
TortoiseSVN 1.6.99, Build 21703 - 32 Bit -dev, 2011/07/19 08:52:36

Subversion Server-Version:
1.3.1 (r19032)

 

 

Best regards
Benjamin Lilienthal

 
Received on 2011-08-05 23:17:41 CEST

This is an archived mail posted to the Subversion Dev mailing list.