[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Ruby Bindings on Windows (Was 1.7.0-alpha2 tarballs up for signing / testing)

From: Paul Burba <ptburba_at_gmail.com>
Date: Wed, 22 Jun 2011 09:56:28 -0400

On Wed, Jun 22, 2011 at 1:02 AM, Joe Swatosh <joe.swatosh_at_gmail.com> wrote:
> Hi Paul,
>
> On Tue, Jun 21, 2011 at 7:11 PM, Paul Burba <ptburba_at_gmail.com> wrote:
>> On Mon, Jun 20, 2011 at 5:54 PM, Hyrum K Wright <hyrum_at_hyrumwright.org> wrote:
>>> All,
>>>
>
>
>>
>> TESTED:
>> -------
>> [Release-Build] x[ fsfs | bdb ] x [ file | svn | http (neon) | http (serf) ]
>> Ruby bindings
>>
>> RESULTS:
>> --------
>> All Pass
>>
>> PLATFORM:
>> ---------
>> MS Windows 7 Home Premium 6.1.7600 Build 7600
>> Intel Core i7 M 620 2.67GHz 4 GB RAM
>> Microsoft Visual Studio 2008 Version 9.0.30729.1 SP
>>
>> DEPENDENCIES:
>> -------------
>
>
>> Ruby: ruby 1.8.7
>
> I'm curious about your Ruby version, are you using a prepackaged mingw
> build or are you building it yourself or ...?

Hi Joe,

I built it myself from ftp://ftp.ruby-lang.org/pub/ruby/1.8/ruby-1.8.7-p299.zip

I also have this patch applied to reflect my particular setup (BDB
4.8.30 and a static svn build):

[[[
Index: subversion/bindings/swig/ruby/test/windows_util.rb
===================================================================
--- subversion/bindings/swig/ruby/test/windows_util.rb (revision 1138460)
+++ subversion/bindings/swig/ruby/test/windows_util.rb (working copy)
@@ -93,12 +93,11 @@
           %r'^\s*#define\s+APR_MAJOR_VERSION\s+(\d+)' =~
apr_version_include.read
           apr_major_version = $1 == '0' ? '' : "-#{$1}"

- targets = %W(svnserve.exe libsvn_subr-1.dll libsvn_repos-1.dll
- libsvn_fs-1.dll libsvn_delta-1.dll
+ targets = %W(svnserve.exe
                        libaprutil#{apr_major_version}.dll
                        libapr#{apr_major_version}.dll
                        libapriconv#{apr_major_version}.dll
- libdb44.dll libdb44d.dll)
+ libdb48.dll libdb48d.dll)
           ENV["PATH"].split(";").each do |path|
             found_targets = []
             targets.each do |target|
]]]

Not sure if this is a known issue on Win 7 or not, but I also need to
run the command prompt as an administrator or svnserve won't start:

  1) Error:
test_add_force(SvnClientTest):
RuntimeError: Failed to create test-svn-server--port-64282: binPath=
"\"C:\SVN\src-trunk\subversion\bindings\swig\ruby\svnserve\svnserve.exe\"
--service --root
\"C:\SVN\src-trunk\subversion\bindings\swig\ruby\repos\" --listen-host
127.0.0.1 --listen-port 64282" DisplayName=
"test-svn-server--port-64282" type= "own"
C:/SVN/src-trunk/subversion/bindings/swig/ruby/test/windows_util.rb:43:in
`service_control'
C:/SVN/src-trunk/subversion/bindings/swig/ruby/test/windows_util.rb:134:in
`setup_svnserve'
C:/SVN/src-trunk/subversion/bindings/swig/ruby/test/util.rb:59:in `setup_basic'
C:/SVN/src-trunk/subversion/bindings/swig/ruby/test/test_client.rb:30:in `setup'

> (I didn't think this of interest to the SVN dev list in general, if
> you disagree, please feel free to include it in the reply).

Might be of use to someone so I'm including dev.

Paul

> Thanks,
>
> --
> Joe
Received on 2011-06-22 15:57:00 CEST

This is an archived mail posted to the Subversion Dev mailing list.