On Wed, Apr 27, 2011 at 15:43, <hwright_at_apache.org> wrote:
> +++ subversion/trunk/subversion/include/svn_wc.h Wed Apr 27 19:43:58 2011
> @@ -3020,10 +3020,10 @@ typedef struct svn_wc_info_t
> * representation, or #SVN_INVALID_FILESIZE if unknown.
> * Not applicable for directories.
> - svn_filesize_t working_size64;
> + svn_filesize_t working_size;
Can we renamed this to recorded_size, and its companion to
recorded_mod_time? I believe these two names better reflect the
semantics of these fields.
(unless the file is always stat'd before filling in this field...
which I don't think it does?)
> +++ subversion/trunk/subversion/libsvn_client/info.c Wed Apr 27 19:43:58 2011
> @@ -274,10 +257,11 @@ build_info_for_entry(svn_info_t **info,
> /* ### Some fields we could fill out based on the parent dir's entry
> or by looking at an obstructing item. */
> static svn_error_t *
> -build_info_for_unversioned(svn_info_t **info,
> +build_info_for_unversioned(svn_info2_t **info,
> apr_pool_t *pool)
> - svn_info_t *tmpinfo = apr_pcalloc(pool, sizeof(*tmpinfo));
> + svn_info2_t *tmpinfo = apr_pcalloc(pool, sizeof(*tmpinfo));
> + tmpinfo->wc_info = apr_pcalloc(pool, sizeof (*tmpinfo->wc_info));
You didn't include the same warning comment here :-P
> @@ -288,11 +272,7 @@ build_info_for_unversioned(svn_info_t **
> tmpinfo->last_changed_date = 0;
> tmpinfo->last_changed_author = NULL;
> tmpinfo->lock = NULL;
> - tmpinfo->working_size = SVN_INFO_SIZE_UNKNOWN;
> tmpinfo->size = SVN_INFO_SIZE_UNKNOWN;
This is incorrect. It should be SVN_INVALID_FILESIZE.
The new code should never use SVN_INFO_SIZE_UNKNOWN. That is a bogus,
deprecated constant for the old incorrect "size" field which was only
an apr_size_t. I saw you moved the constant recently. You may want to
mark it deprecated (and why).
Received on 2011-04-28 00:49:32 CEST