On Sat, 2011-03-26, Daniel Shahaf wrote:
> >From doc string of svn_wc_diff_callbacks4_t:
> "Note that @a path is a relative path, not just the basename of the path."
> >From merge_file_added() (which implements svn_wc_diff_callbacks4_t.file_added):
> Given that MINE_ABSPATH is the parameter called PATH in the doc string,
> I think the contradiction is obvious...
I notice that the doc string no longer documents the form of "@a path":
that sentence you quoted is not there; but the problem still exists.
It would be good to rename the function parameters in the struct to
better names, like the names used in merge_file_added():
"mine_[abs?]path", "older_abspath", etc. instead of "path", "tmpfile1",
Received on 2011-04-13 12:30:39 CEST