Stefan Sperling wrote on Mon, Oct 25, 2010 at 16:13:58 +0200:
> On Mon, Oct 25, 2010 at 09:50:41AM -0400, C. Michael Pilato wrote:
> > I don't think it's so terribly important to match the 'patch' command's
> > option name with our option's primary name, but it's a nice-to-have
> > achievable via the option aliases. If we're going to go that route, though,
> > then we should choose an option's primary name as if there was nothing else
> > to model after. I mean, is --strip-count as descriptive as it can be, or
> > would something else serve better? --strip-components-count?
> > --ignore-path-components-count?
> The need for such long names originates from the fact that options in
> Subversion are global, rather than specific to a subcommand.
> Because option names by themselves aren't tied to a context it's hard to
> predict whether some other subcommand might want to use the same or a
> similarly named option some day.
> Anyway, let's keep aliases as short-hands for interactive use, rather
> than as alternative long-option names. I'm fine with renaming
> --strip-count to --strip and aliasing it to --st. Or maybe not even
> bother with aliasing it since --strip is reasonably short anyway.
Perhaps do the same to --show-diff and --diff?
And removing the word 'patch' from 'opt_old_patch_target_names'?
Received on 2010-10-25 20:09:21 CEST