[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: hotcopy fails on fsfs.conf that has never been created

From: Philip Martin <philip.martin_at_wandisco.com>
Date: Fri, 23 Jul 2010 18:17:52 +0100

Daniel Shahaf <d.s_at_daniel.shahaf.name> writes:

> Old repositories don't have a fsfs.conf file. I think we should either make
> 'hotcopy' tolerate the absence of that file, or make 'svnadmin upgrade' create
> it; otherwise,
>
> svnadmin1.5 create foo
> svnadmin1.7 hotcopy foo bar
>
> will fail with the error Александр quotes.
>
> Anybody has a preference regarding which solution to take?

Do both.

What about the --pre-1.4-compatible and --pre-1.5-compatible options
to create, should we avoid creating the file when they are used?

-- 
Philip
Received on 2010-07-23 19:25:20 CEST

This is an archived mail posted to the Subversion Dev mailing list.