[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Build-bots always failing [was: svn trunk r37930: FAIL (win32-xp VS2005)]

From: Julian Foad <julianfoad_at_btopenworld.com>
Date: Thu, 04 Jun 2009 22:10:16 +0100

What's up with the Windows and Ubuntu build-bots always failing? (They
seem to have been failing for many weeks at least.)

- Julian

buildbot_at_mobsol.be wrote:
> Full details are available at:
> http://crest.ics.uci.edu/buildbot/builders/win32-xp%2520VS2005/builds/229
>
> Author list: hwright
>
> Build Slave: djh-xp-vse2005
>
>
> Subversion Buildbot
> http://crest.ics.uci.edu/buildbot/
>
>
> Last 100 lines of the build log (step: Test fsfs+ra_local ):
>
> svn: Target path '/A' does not exist
>
> PASS: update_tests.py 56: update wc of dir to rev not containing this dir
>
> CLEANUP: svn-test-work\working_copies\update_tests-56
>
> CLEANUP: svn-test-work\repositories\update_tests-56
>
> CLEANUP: svn-test-work\working_copies\update_tests-56.other
>
> CMD: M : \ s v n - a u t o - t e s t \ f s f s \ s u b v e r s i o n \ s v n \ s v n . e x e u p " s v n - t e s t - w o r k \ w o r k i n g _ c o p i e s \ u p d a t e _ t e s t s - 5 6 . o t h e r " - - c o n f i g - d i r " M : \ s v n - a u t o - t e s t \ f s f s \ s u b v e r s i o n \ t e s t s \ c m d l i n e \ s v n - t e s t - w o r k \ l o c a l _ t m p \ c o n f i g " - - p a s s w o r d r a y j a n d o m - - n o - a u t h - c a c h e - - u s e r n a m e j r a n d o m exited with 1
>
> Exception in thread Thread-9:
> Traceback (most recent call last):
> File "C:\Python24\lib\threading.py", line 442, in __bootstrap
> self.run()
> File "C:\svn-builder\djh-xp-vse2005\build!
> \subversion\tests\cmdline\svntest\main.py", line 1048, in run
> self.run_one(next_index)
> File "C:\svn-builder\djh-xp-vse2005\build\subversion\tests\cmdline\svntest\main.py", line 1072, in run_one
> result, stdout_lines, stderr_lines = spawn_process(command, 1, None, *args)
> File "C:\svn-builder\djh-xp-vse2005\build\subversion\tests\cmdline\svntest\main.py", line 468, in spawn_process
> infile, outfile, errfile, kid = open_pipe([command] + list(varargs))
> File "C:\svn-builder\djh-xp-vse2005\build\subversion\tests\cmdline\svntest\main.py", line 416, in open_pipe
> close_fds=not windows)
> File "C:\Python24\lib\subprocess.py", line 490, in __init__
> _cleanup()
> File "C:\Python24\lib\subprocess.py", line 398, in _cleanup
> inst.poll()
> File "C:\Python24\lib\subprocess.py", line 739, in poll
> _active.remove(self)
> ValueError: list.remove(x): x not in list
>
> CMD: C : \ P y t h o n 2 4 \ p y t h o n . e x e " C : \ s v n - b u i l d e r \ d j h - x p - v s e !
> 2 0 0 5 \ b u i l d \ s u b v e r s i o n / t e s t s / c m d l i n e
> / u p d a t e _ t e s t s . p y " 3 2 - c " - - f s - t y p e = f s f s " " - - u r l = f i l e : / / / M % 3 A / s v n - a u t o - t e s t / f s f s / s u b v e r s i o n / t e s t s / c m d l i n e " - v - - c l e a n u p " - - h t t p - l i b r a r y = n e o n " " - - s e r v e r - m i n o r - v e r s i o n = 7 " exited with 1
> END: update_tests.py
[...]

------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=462&dsMessageId=2359534
Received on 2009-06-04 23:10:52 CEST

This is an archived mail posted to the Subversion Dev mailing list.