[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: r37103 - trunk/subversion/libsvn_wc

From: Greg Stein <gstein_at_gmail.com>
Date: Wed, 8 Apr 2009 17:19:25 +0200

On Wed, Apr 8, 2009 at 17:00, Stefan Sperling <stsp_at_elego.de> wrote:
> On Wed, Apr 08, 2009 at 07:43:06AM -0700, Greg Stein wrote:
>> Author: gstein
>> Date: Wed Apr  8 07:43:05 2009
>> New Revision: 37103
>>
>> Log:
>> Get the wcprops out of the access baton.
>
> Weren't wcprops a near equivalent to http cookies, to be used as
> a data store by ra_neon and ra_serf? While here, can we rename
> them to something that reflects this usage better, like
> "dav-cookies" or something?
>
> I'm requesting this because the current terminology is highly
> confusing, to the point where sbutler and I originally envisioned
> using wcprops to store tree conflict info, and then people said
> "noooo that's not what these are for". I think that happened
> just because their current name is not descriptive enough.

Good idea.

They were called wcprops because the original vision was "properties
managed solely by the wc. repos will never see them." And the first
user was ra_dav.

Ended up that no other use ever came along, and http v2 doesn't even
use them. We're going to keep them for http v1 usage, but yes: let's
go ahead and rename them. It is doubtful that we'll ever see another
need for the concept. And if we *do*, then we can revisit the naming
and mechanisms.

Cheers,
-g

------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=462&dsMessageId=1597993
Received on 2009-04-08 17:20:49 CEST

This is an archived mail posted to the Subversion Dev mailing list.