[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn trunk r36204: FAIL (x64-ubuntu gcc)

From: Hyrum K. Wright <hyrum_wright_at_mail.utexas.edu>
Date: Wed, 4 Mar 2009 14:31:43 -0600

On Feb 27, 2009, at 9:12 PM, Joe Swatosh wrote:

> On Fri, Feb 27, 2009 at 4:52 PM, <buildbot_at_mobsol.be> wrote:
>> Full details are available at:
>> http://www.mobsol.be/buildbot/builders/x64-ubuntu%2520gcc/builds/518
>>
>> Author list: rhuijben
>>
>> Build Slave: x64-ubuntu
>>
>>
>> Subversion Buildbot
>> http://www.mobsol.be/buildbot/
>>
>>
>> Last 100 lines of the build log (step: Test bindings ):
>>
>> ------------------------------------------------------
>> http://subversion.tigris.org/ds/viewMessage.do?dsForumId=552&dsMessageId=1241850
>>
>> To unsubscribe from this discussion, e-mail: [svn-breakage-unsubscribe_at_subversion.tigris.org
>> ].
>>
>
> Hyrum,
>
> Would you please run the failing ruby binding test alone (to ensure
> there isn't
> some stale state in the tests or the bindings themselves causing the
> problem)?
>
> ruby test/run-test.rb -ntest_status_with_depth
>
> from the ruby bindings directory ought to do the trick.

hwright_at_orac:~/dev/svn-trunk/subversion/bindings/swig/ruby$ ruby test/
run-test.rb -ntest_status_with_depth
Loaded suite .
Started
E
Finished in 1.731787 seconds.

   1) Error:
test_status_with_depth(SvnClientTest):
Svn::Error::WcNotLocked:
subversion/libsvn_wc/lock.c:910: Svn::Error::WcNotLocked: Unable to
lock 'wc-tmp/wc/A/B'
/home/hwright/dev/svn-trunk/subversion/bindings/swig/ruby/svn/util.rb:
86:in `svn_client_status3'
/home/hwright/dev/svn-trunk/subversion/bindings/swig/ruby/svn/util.rb:
86:in `status3'
/home/hwright/dev/svn-trunk/subversion/bindings/swig/ruby/svn/
client.rb:176:in `status'
/home/hwright/dev/svn-trunk/subversion/bindings/swig/ruby/test/
test_client.rb:469:in `test_status_with_depth'
/home/hwright/dev/svn-trunk/subversion/bindings/swig/ruby/test/
test_client.rb:468:in `each'
/home/hwright/dev/svn-trunk/subversion/bindings/swig/ruby/test/
test_client.rb:468:in `test_status_with_depth'
/home/hwright/dev/svn-trunk/subversion/bindings/swig/ruby/test/util.rb:
181:in `make_context'
/home/hwright/dev/svn-trunk/subversion/bindings/swig/ruby/test/
test_client.rb:463:in `test_status_with_depth'

1 tests, 0 assertions, 0 failures, 1 errors

> BTW the java tests are failing, too.

Thanks. I think that has something to do with the recent changes to
the build system.

-Hyrum

------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=462&dsMessageId=1268453
Received on 2009-03-04 21:32:00 CET

This is an archived mail posted to the Subversion Dev mailing list.